Status

SeaMonkey
Help Documentation
--
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Brant Gurganus, Assigned: Ian Oeschger (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020419
BuildID:    2002041903

The javascript link that opens Mozilla Help for Debug > Events does not work.

Reproducible: Always
Steps to Reproduce:
1. Open preferences.
2. Navigate to Debug > Events.
3. Click Help.

Actual Results:  Mozilla Help opens, but page does not open.

Expected Results:  Page opens.

In the JavaScript console, the following appears when the button is pressed:
Error: uri has no properties
Source File: chrome://help/content/help.js
Line: 275
(Assignee)

Comment 1

16 years ago
All of these are examples of help buttons for which no help has yet been
created. Most of these are mozilla-only UI, too, like the DOM Inspector pref
panel and so on. ACCEPTING. We can at least put pointers to some basic help
content for these in the UI (e.g, in pref-help.js, where the context keys for
the pref panel are listed), even if there is as yet no specific contextual help.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

16 years ago
I am nominating this for 1.0 since it will give users a bad message if they
click help and don't receive any.
Keywords: mozilla1.0
(Assignee)

Comment 3

16 years ago
Patch for these bugs is over in 129540:
http://bugzilla.mozilla.org/attachment.cgi?id=83604&action=view
Where there is not help content for the panels listed here, I open the Welcome page.
(Assignee)

Comment 4

16 years ago
These are FIXED with 145331, which sets the default topic properly when the
context ID is not available.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.