Closed Bug 1389302 Opened 3 years ago Closed 3 years ago

Intermittent Mac stylo table-background/backgr_border-table-quirks.html == table-background/backgr_border-table-quirks.html | image comparison, max difference: 32, number of differing pixels: 86

Categories

(Core :: Layout: Tables, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Summary: Intermittent table-background/backgr_border-table-quirks.html == table-background/backgr_border-table-quirks.html | image comparison, max difference: 32, number of differing pixels: 86 → Intermittent Mac stylo table-background/backgr_border-table-quirks.html == table-background/backgr_border-table-quirks.html | image comparison, max difference: 32, number of differing pixels: 86
Duplicate of this bug: 1391443
this is a stylo specific failure, but at a very high rate.  

here is a recent log:
https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=124828125

and the analyzer:
https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ZE661qR-QUORhvj67Bgrvw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

:jet, could you help find someone who knows about this test and/or stylo to look into fixing this intermittent failure?
Flags: needinfo?(bugs)
Whiteboard: [stockwell needswork]
:jet, this is 2 weeks in with a high failure rate, is this something we can look at or consider disabling on osx/opt for stylo builds?
We have already "fuzzy-if(styloVsGecko&&winWidget,32,88)", we should just add cocoaWidget s well.
Flags: needinfo?(bugs)
https://hg.mozilla.org/try/rev/fcd708fca47b8b492e8a1b869dce6e8df983a600
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Intent to ship: https://groups.google.com/forum/#!topic/mozilla.dev.platform/ELX9G6OOAjw

The try in comment 10 has lots of oranges, but all of them are unrelated to PerformanceObserver.
Wrong bug..
I haven't re-triggered for the tyr in comment 10, but it should fix this intermittent failure.
Comment on attachment 8904888 [details]
Bug 1389302 - Add fuzzy-if for cocoaWidget as well as winWidget.

https://reviewboard.mozilla.org/r/176664/#review181702
Attachment #8904888 - Flags: review?(xidorn+moz) → review+
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e88a10a30966
Add fuzzy-if for cocoaWidget as well as winWidget. r=xidorn
https://hg.mozilla.org/mozilla-central/rev/e88a10a30966
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.