If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

select multiple AND form.MySelect.option[0]

VERIFIED INVALID

Status

()

Core
HTML: Form Submission
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: etud, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

It's impossible to select multiples entries in a <select....multiple> if those
entries are not continuous.
With Javascript if you have document.Myform.MySelect.option[0].selected=true the
text of the option 0 is not on the screen, if you have option[i] with i!=0 no
problem

Reproducible: Always
Steps to Reproduce:
1.having a multiple select like here http://bugzilla.mozilla.org/reports.cgi
2.having options[0] like here http://horaire.skreel.org/test_select.html
3.

Actual Results:  ?
Created attachment 80282 [details]
Testcase

The attached testcase worksforme, linux trunk build 2002-04-20-07.  Is this
what you mean?	If not, could you please _clearly_ explain the problem, or
better yet produce a small HTML file that shows it?
etud, I saw on your 2nd link (http://horaire.skreel.org/test_select.html) that
when I select SGBD, I can't select MySQL on the right (the only possible
selection). Is that what you mean?
In that case, I vcan confirm the problem.
(Reporter)

Comment 3

16 years ago
http://horaire.skreel.org/test_select.html
OK that's it when you select SGBD you can't select MySQL, but another problem is
that noramlly MySQL should be pre-selected, and when you select langage ASP
should be pre-selected and the same with OS -> FreeBSD.

The second part of the bug ( in fact a second bug ? ) is that with a tag select
multiple you can't select multiples values see:
http://horaire.skreel.org/test_select.html
How are you trying to select multiple items? I do it with ctrl-click, and that
works.

Comment 5

16 years ago
resolving invalid due to lack of response.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.