Closed Bug 1389408 Opened 2 years ago Closed 2 years ago

Compile busted: Windows: ImageBitmap.h(66): error C3646: 'mAlphaType': unknown override specifier - Linux: ImageBitmap.h:66:3: error: 'gfxAlphaType' does not name a type - Mac: ImageBitmap.h:66:3: error: unknown type name 'gfxAlphaType'

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1387912

People

(Reporter: jorgk, Unassigned)

Details

Attachments

(1 obsolete file)

As per:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=2d37489b09aa224a3931bfe7bf913053994dafb0

Quoting Linux, error varies on Mac and Windows.

/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/mozilla/dom/ImageBitmap.h:66:3: error: 'gfxAlphaType' does not name a type [log…]
 
/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/mozilla/dom/ImageBitmap.h:203:15: error: 'gfxAlphaType' has not been declared [log…]
 
/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/mozilla/dom/ImageBitmap.h:275:9: error: 'gfxAlphaType' does not name a type [log…]
 
/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/mozilla/dom/ImageBitmap.h:203:41: error: 'gfxAlphaType' has not been declared [log…]
Flags: needinfo?(mchang)
M-C last good: 5322c03f4c85
M-C first bad: 253a8560dc34

Range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5322c03f4c85&tochange=253a8560dc34
Attached patch 1389408.patch (obsolete) — Splinter Review
Tomcat, can you please land this on M-C.
Flags: needinfo?(cbook)
Oh, Tomcat is on PTO.
Flags: needinfo?(aryx.bugmail)
Comment on attachment 8896168 [details] [diff] [review]
1389408.patch

Requesting review from a few Graphics people listed for dom/canvas.
Attachment #8896168 - Flags: review?(mstange)
Attachment #8896168 - Flags: review?(mchang)
Attachment #8896168 - Flags: review?(lsalzman)
Attachment #8896168 - Flags: review?(jmuizelaar)
Attachment #8896168 - Flags: review?(jnicol)
An equivalent patch was recently r+'d in bug 1387912, and I just landed it there.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mchang)
Flags: needinfo?(cbook)
Flags: needinfo?(aryx.bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1387912
Attachment #8896168 - Flags: review?(mstange)
Attachment #8896168 - Flags: review?(mchang)
Attachment #8896168 - Flags: review?(lsalzman)
Attachment #8896168 - Flags: review?(jnicol)
Attachment #8896168 - Flags: review?(jmuizelaar)
Comment on attachment 8896168 [details] [diff] [review]
1389408.patch

Review of attachment 8896168 [details] [diff] [review]:
-----------------------------------------------------------------

Please put the #include "gfxTypes.h" before the #include "mozilla/*" so some sense of order is maintained.
Attachment #8896168 - Flags: review+
Comment on attachment 8896168 [details] [diff] [review]
1389408.patch

Thanks, but that already got landed with the gfxTypes.h after the "mozilla/" block:
https://hg.mozilla.org/mozilla-central/rev/65826179c86e#l1.12
Attachment #8896168 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.