css stylesheet never loaded / never applied

VERIFIED INVALID

Status

()

Core
Layout
--
major
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Bruno Beloff, Assigned: Marc Attinasi)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020516 and others

The stylesheet (at http://www.opmath.com/styles/opmath.css) is never used or
never loaded.  Thus the text on the rednered page is the default  font, size, etc.

Note that:

1. Netscape 4.7.x on Solaris, Netscape 6 on Solaris, Mozilla 0.94 on Mandrake,
and IE 5.0.1 on Mac OS X all render these pages okay.

2. Both the html and the css documents validate ok with the w3c validator.

3. Mozilla on Mac OS X (the only browser I can find with this problem) does
render the pages okay when they are loaded from the local file system - the
failure may only be when pages are accessed over http.

 

Reproducible: Always
Steps to Reproduce:
View http://www.opmath.com/index.html with Mozilla.

Actual Results:  Page is rendered with correct overall layout, images and
scripts.  The text content, however, is not affected by the stylesheet
specifications.

Expected Results:  Applied stylesheet.

HTML and CSS documents generated with BBEdit 6.5.2 on Mac OS X, generated in
UNIX partition on Mac OS X, ISP's HTTP host is unspecified UNIX.
(Reporter)

Comment 1

16 years ago
Created attachment 80271 [details]
expected layout (rendered by IE 5.0.1)
(Reporter)

Comment 2

16 years ago
Created attachment 80272 [details]
actual layout (rendered by mozilla)

Comment 3

16 years ago
The problem is that the .css file is served as 'text/html'.
In order for a css stylesheet to be applied in strict mode, the css file must
have a content-type of 'text/css'.
You will need to modify your server to send css files as text/css or use a
DOCTYPE that does not cause strict mode.

Marking INVALID ...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Verified.  Bruno, see http://www.mozilla.org/docs/web-developer/quirks/ for more
information on the two rendering modes, and see the release note at
http://mozilla.org/releases/mozilla1.0/#devel that talks about this situation
and the various ways of dealing with it.
(really VERIFIED)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.