Text displays wrong with certain styles in layers-free mode

RESOLVED FIXED in Firefox 57

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ethlin, Assigned: ethlin)

Tracking

unspecified
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
The test 'reftests/w3c-css/submitted/text-decor-3/text-emphasis-style-property-002.html'[1] can reproduce this problem. I guess the display item's boundary is wrong.

[1] https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/I3UAGPuwTZSS7V6gNOAdlA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1
Comment hidden (mozreview-request)
Assignee

Updated

2 years ago
Assignee: nobody → ethlin
Comment on attachment 8896881 [details]
Bug 1389433 - Fix the offset of the fallback image for layers-free.

https://reviewboard.mozilla.org/r/168172/#review173768
Attachment #8896881 - Flags: review?(mtseng) → review+

Comment 3

2 years ago
Pushed by ethlin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/15bf2faef292
Fix the offset of the fallback image for layers-free. r=mtseng

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/15bf2faef292
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.