Closed Bug 138945 Opened 23 years ago Closed 22 years ago

links in jscript under-menu do not work

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kwbolte, Assigned: joki)

References

()

Details

(Whiteboard: [eurocontest])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

links in jscript under-menu do not work

Reproducible: Always
Steps to Reproduce:
1.Open link
2.click on an item of the list "Produkte" (left side)
3.a menu opens - click on an item in this menu


Actual Results:  nothing - link does not work

Expected Results:  Page
http://computer.toshiba.de/cgi-bin/ToshibaCSG/model_index_page.jsp?z=25&ID=2326.000000&jz=60314
should open.

- Works in Netscape Communicator 4.78, works not in Konqueror 3.0.0
- I think its a script dividing in NS 4 and IE - users.
Whiteboard: [eurocontest]
worksforme linux trunk 2002042015

are you spoofing your user agent?
Seeing this on OS X/1.0RC1... only with the first items in that list (with the
"+" next to them instead of the arrows)... don't have time check the javascript
source to see if this should be moved to Tech Evangelism.

Only error in console on reloading the page was:

Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://computer.toshiba.de/HM_ScriptDOM.js :: HM_f_MakeMenu :: line 341"  data: no]
OS: Linux → All
Hardware: PC → All
confirmed on 1.0RC1, Linux. There comes a JS Exception in JS Console
Status: UNCONFIRMED → NEW
Ever confirmed: true
worksforme, linux 2002-04-20-07 with these steps:

1) Click "Desktop"
2) Click "Equium 3000 Serie"

I go to the right page.

Kai, are you seeing the bug if you do that?  If so, what's the exception in the
JS console?  You can copy out of there by selecting and choosing "Copy" from the
menu, then pasting with Ctrl-C or opening xclipboard to get it into PRIMARY.
even clicking on "Desktop" does nothing here.

The error:

Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://computer.toshiba.de/HM_ScriptDOM.js :: HM_f_MakeMenu :: line 341"  data: no]
wfm with win2k build 20020420..
Boris, nothing happens when clicking on "Desktop".

JS console:
Error: syntax error
Source File: javascript:
http://computer.toshiba.de/cgi-bin/ToshibaCSG/options_and_accessories_homepage.jsp?z=44
Line: 1, Column: 87
Source Code:
http://computer.toshiba.de/cgi-bin/ToshibaCSG/options_and_accessories_homepage.jsp?z=44
Same thing occurs on http://www2.mil.se/index.php?lang=eng

Try clicking the menu items under "Contents", "Organization", "Other languages"
or "Points of Contact", nothing happens for me. Curiously enough, if I
right-click the item and select "Open in new tab" it works as expected. (I'm
using Galeon.)
Oh, and I use Mozilla 1.0 RC1 in Galeon, and if I try using Mozilla as a
standalone app, the same thing occurs - so it's not Galeon causing it.
Blocks: 113492
The problems reported here are not JS Engine problems. Let me reassign
this to Browser-General and ask kwbolte@gmx.de, daniel.perup@swipnet.se,
and christophercasciano@yahoo.com if they can still reproduce this bug
with an up-to-date build.

I am unable to reproduce it using Mozilla trunk binaries 20020617xx
on WinNT and Linux. Every link works for me on every submenu on 
both the websites mentioned above (the given one plus Comment #8).
I never get any errors in the JavaScript Console, either -

If anyone is still able to reproduce it, try this: what happens
if you run Mozilla under a brand-new profile? You can always make
the Profile Manager come up by launching Mozilla from a console
window this way:

         [(path to Mozilla)] ./mozilla -profilemanager

Does the bug still occur under a new profile?
Assignee: rogerl → Matti
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → imajes-qa
I can reproduce this bug with Mozilla 1.1a Linux
<Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610>.

JavaScript Console says nothing.

Creating a new profile does not help.

Like Chris wrote - if you click on the items with '+' next to them (for example
"Desktops"), a menu opens and clicking something there does nothing but the menu
closing.

BUT - the bug does NOt appaer under 
Netscape 7pr1 Windows 98
<Netscape 7.0 Preview Release 1 Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.0rc2
Gecko/20020512 Netscape/7.0b1> 
and Mozilla 1.0 Windows XP
<Mozilla 1.0 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0)
Gecko/20020530>.
Reassigning to Event Handling. We've had a number of reports of 
this recently; unfortunately, no progress has been made toward 
finding the reason. It seems to affect Linux users only, and 
perhaps only those using a certain window manager. 

Some users have reported that restarting the X server on Linux
can make this problem go away! Others report that RIGHT-clicking
menu items works successfully; only left-clicking them does not.

See:

bug 134904   JavaScript menus don't work
bug 132592   svenskaspel.se - no response on menu click
bug 132968   Erratic function of dynamic menus



Could people comment on:

1. What window manager are you using on Linux?
2. Does re-starting X ever make the problem go away?
3. Does right-clicking on the menu items work? 
Assignee: Matti → joki
Component: Browser-General → Event Handling
QA Contact: imajes-qa → rakeshmishra
I use Mozilla 1.0 and Sawfish 1.0. 

The site http://www2.mil.se/index.php?lang=eng has the problem with menus not
working. 

For example, point at the "Contents" menu and try to select "Officers'
training". Nothing happens for me. Do note that the status bar displays the URL
which the menu item points to. 

Right clicking the menu item and selecting "Open link in new tab" or "...new
window" will work as expected though.

Restarting X doesn't seem to do much good. Please tell me if I can be of any
more help.
I tried creating a new profile with "mozilla -profilemanager", which did not fix
the problem.
QA Contact: rakeshmishra → trix
The Toshiba-Site now works with Mozilla 1.3a (Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.3a) Gecko/20021212),but only if you click the symbols not the text
of the (sub-)menu.
Right-click on the submenu-item does NOT work.
Menu at http://www2.mil.se does NOT work for me.
I'm using X-free 4.2.0 and KDE 3.0.5a.
both the toshiba site and  http://www2.mil.se WFM under 1.4b/OS X... can someone
elese confirm so I ca WFM this?
Confirming, works for me in  Mozilla Firebird/0.6-20030506 Linux/XFree 4.2.0.
Great!
toshiba.de and mil.se works completly with the new 1.4b build. 
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507)
resolving WFM based on multiple reports
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.