Closed Bug 1389459 Opened 3 years ago Closed 2 years ago

webextension: Proxy API is broken in FF 56

Categories

(WebExtensions :: Request Handling, defect)

56 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1389718

People

(Reporter: crownofdesign, Unassigned)

Details

(Whiteboard: [proxy])

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36

Steps to reproduce:

Use this example:
https://github.com/mdn/webextensions-examples/tree/master/proxy-blocker

change browser.proxy.registerProxyScript to browser.proxy.register
DIRECT 1234 to DIRECT

Try to test


Actual results:

Error in the console:
Error: Could not establish connection. Receiving end does not exist.

I can watch http://example.com/, it is not blocked


Expected results:

Example's code must be updated and example must work in FF56
56.0b1 (64-bit)
Component: General → WebExtensions: Request Handling
Whiteboard: [proxy]
As for the 2nd beta, Proxy API for packed embedded webextension, installed from the file is working. But for temporary pure webextension it is not working
Not working also in FF 56.0b3.

As said before in the example on line 21:

--- Begin Background script code
browser.runtime.sendMessage(newSettings.blockedHosts.newValue, {toProxyScript: true});
--- End

this message is never received by the pac file script.

--- Begin Pacfile script code
browser.runtime.onMessage.addListener((message) => {
  blockedHosts = message;
});
--- End

Messages from the pac file to the background script work fine. I can send messages and show logs on console.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389718
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.