Regression in scroll performance (100% CPU)

RESOLVED DUPLICATE of bug 102321

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 102321
16 years ago
16 years ago

People

(Reporter: Phil "clef" Sweeney, Assigned: Marc Attinasi)

Tracking

({perf, regression})

Trunk
x86
Windows XP
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Between these two nightly trunk builds, something regressed so that many pages
now have terrible scrolling performance along with 100% CPU usage (rendering
time is also affected).

2002-04-16-06/  ID: 2002041603   Good
2002-04-17-17/  ID: 2002041710   Bad

Another example page: http://www.aintitcool.com/

As far as I've seen, the RC1 branch has not regressed.
Yes, I see this, and it is terrible. 

Someone destroyed my webpage! Bastards!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
If we could figure out a recipe for this slowdown, that would make it easier to
track down.

I'm CC'ing people who checked in changes to gecko during this time period -- if
you know it's not you, feel free to un-CC. :-)
Keywords: perf, regression

Comment 4

16 years ago
looks like a dup of bug 138034?

Comment 5

16 years ago
BTW bug 138119 looks also related. 
(Reporter)

Comment 6

16 years ago
Note, this is a regression from only days ago.  This needs to be restored back
to it's previous performance before extra work can be done on perf in those
other bugs.
I don't see this problem on Linux... are people seeing this on Win9x?  Or just
Win2k/NT?  Ccing dcone, since he's been handling most of the "scrolling perf on
NT sucks" bugs...

*** This bug has been marked as a duplicate of 102321 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.