Context menuitem of WebExtensions should be disabled If WebExtensions execution is restricted on tab/url

RESOLVED DUPLICATE of bug 1385073

Status

()

Toolkit
WebExtensions: Untriaged
P2
normal
RESOLVED DUPLICATE of bug 1385073
4 months ago
3 months ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({ux-consistency})

57 Branch
ux-consistency
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

4 months ago
Reproducible: always

Steps To Reproduce:
1. Install some WebExtensions which has context menuitem
   Tab contextmenu : FoxyTab
                     https://addons.mozilla.org/en-US/firefox/addon/foxytab/?src=userprofile
   ContentArea contextmenu : Page Zoom We
                             https://addons.mozilla.org/en-US/firefox/addon/zoom-page-we/?src=search
2. Open https://addons.mozilla.org/en-US/firefox/
3. Right click on the Tab and Choose FoxyTab > Copy Tab Title
4. Right click on the page and Choose Page Zoom We > Zoom Type

Actual Results:
These menu is enabled. However, refused to execution the menu.

Expected Results:
Context menu should be disabled if WebExtensions execution is restricted on tab/url
Priority: -- → P2
I do not agree with this change request when this would be default behaviour. The proposed behaviour should be at least optional; some extensions can still do something useful. Maybe we can make this a manifest.json key?

For example, Translate Now uses the context menu selection context, so it does not need a content script to get the selection. Translate Now can translate some words on addons.mozilla.org and it is praised for supporting addons.mozilla.org by its users.

Comment 2

3 months ago
I think that Geoffrey is right in Comment 1: not all the extensions that use a context menus item are going to inject a content script in the target tab.

Once Bug 1385073 will be fixed, an extension is going to be able to exclude the context menu item from any url that match a defined list of patterns.   

I'm resolving this as a duplicate of Bug 1385073.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1385073
You need to log in before you can comment on or make changes to this bug.