Removing extension using right click does not display no-extension warning

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
10 months ago
8 months ago

People

(Reporter: marius.santa, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8896265 [details]
no message.gif

[Affected versions]:
Firefox 57.0a1(2017-08-10)
Firefox 56.0b2(20170810180547)
Firefox 55.0.1(20170628075643)

[Affected platforms]:
Windows 10 64-bit
Mac Os X 10.12.3


[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Install any webextension (ex. https://addons.mozilla.org/en-US/firefox/addon/adblock-for-youtube/) .
4.Press CTRL+SHIFT+A .
5.Right click on the extension.
6.Click on "Remove".


[Expected Results]:
The "Undo" option is displayed for the extension.


[Actual Results]:
- The extension is removed, nothing is displayed.
- See attached Gif.

Comment 1

10 months ago
Thanks for the report. It looks like this flow has been there a while. Given the impending rewrite of these pages away from XUL and removing this functionality, I don't think this is worth fixing.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX

Comment 2

8 months ago
Is the current Nightly after rewrite? Because the bug still exists.

Either way, shouldn't the bug be marked as "open" and be "resolved" by the new-design addon page, instead of marked as "won't fix"?
You need to log in before you can comment on or make changes to this bug.