Don't fail when an SVG is not found

RESOLVED FIXED in Firefox 56

Status

defect
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

unspecified
Firefox 57
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

2 years ago
We currently fail when we can't find an SVG. This is causing an issue for angular usage, where we currently look for an SVG we can't find.
(Assignee)

Comment 1

2 years ago
Posted patch svg1.patch (obsolete) — Splinter Review
Attachment #8896347 - Flags: review?(jdescottes)
(Assignee)

Comment 2

2 years ago
Posted patch svg1.patch (obsolete) — Splinter Review
Approval Request Comment
[Feature/Bug causing the regression]:1389503
[User impact if declined]: angular applications won't be debuggable
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: 
[Is the change risky?]: no
[Why is the change risky/not risky?]: it removes a throw
[String changes made/needed]:
Attachment #8896349 - Flags: review?(jdescottes)
Attachment #8896349 - Flags: approval-mozilla-beta?
Which versions are affected?  Do we know a regression window?  (It doesn't make sense for this bug to have caused the regression)
Flags: needinfo?(jlaster)
Assuming nightly is affected.
Assignee: nobody → jlaster
(Assignee)

Comment 5

2 years ago
Sorry :lizzard, that was not clear. This bug introduced it: https://bugzilla.mozilla.org/show_bug.cgi?id=1385421

We have fixed the problem on nightly by already landing a patch.
Flags: needinfo?(jlaster)
(Assignee)

Comment 6

2 years ago
:lizzard, looks like the nightly patch did not land yet either. I'll get it reviewed shortly.
(Assignee)

Comment 7

2 years ago
Posted patch svg1.patchSplinter Review
same comments from above
Attachment #8896347 - Attachment is obsolete: true
Attachment #8896349 - Attachment is obsolete: true
Attachment #8896347 - Flags: review?(jdescottes)
Attachment #8896349 - Flags: review?(jdescottes)
Attachment #8896349 - Flags: approval-mozilla-beta?
Attachment #8897479 - Flags: review?(bgrinstead)
Attachment #8897479 - Flags: approval-mozilla-beta?
(Assignee)

Comment 9

2 years ago
It's easy to test this by going to todomvc.com/examples/angularjs/ and adding a breakpoint
Attachment #8897479 - Flags: review?(bgrinstead) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 10

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/643363573c85
Don't fail when an SVG is not found. r=jdescottes
Keywords: checkin-needed

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/643363573c85
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8897479 [details] [diff] [review]
svg1.patch

Fix a devtools issue. Beta56+.
Attachment #8897479 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Jason Laster [:jlast] from comment #2)
> [Is this code covered by automated tests?]: yes
> [Has the fix been verified in Nightly?]: no
> [Needs manual test from QE? If yes, steps to reproduce]: no

Setting qe-verify- based on Jason's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.