Attachment does not appear in the header of the mail window

VERIFIED DUPLICATE of bug 133580

Status

VERIFIED DUPLICATE of bug 133580
17 years ago
11 years ago

People

(Reporter: mozi, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Some attachment are not displayed correctly.

With a .tiff image attachment, if the MIME type is : image/tiff,
mozilla seems not to detect any attachment, and the icon at the upper
right stay "active", showing that mozilla is looking for something
on the imap server (confirmed by a tcpdump, which show activities on
the imap port). Clicking on the "stop" button does not stop the mozilla icon
activity.

Now, if I take exactly the same mail, but change the mime type
from image/tiff to image/jpeg (and let the .tiff image),
mozilla shows that there is an attachment, and I can save it correctly
(but sure, a double-click opens a window with an error, since
it is not a jpeg image but a tiff one).

Reproducible: Always
Steps to Reproduce:
1.send the mail with image/tiff mime type
2.send the mail with image/jpeg mime type
3.try to read both mail : mozilla reports an attachment for the jpeg one, but
not for the tiff one.

Actual Results:  Mozilla silently ignores the attachment with image/tiff mime type.

Expected Results:  Mozilla at least shows that there is an attachment, and let
me save
it.

I run Linux Mandrake 8.2. My server is an IMAP server on a Linux Debian 2.2 .
I get the same error when accessing this server from mozilla on WinNT 4.
The mail an its attachment is correctly downloaded 
(I can see it using the "show source").

Previous version of mozilla (at least 0.9.8) seems not to have this bug.
Opening the image/tiff mail with Sylpheed 0.7.3 works correctly
(I haven't tested other mail client).
(Reporter)

Comment 1

17 years ago
Created attachment 80276 [details]
The mail with image/tiff MIME type : no attachment shown by mozilla.
(Reporter)

Comment 2

17 years ago
Created attachment 80277 [details]
Same mail but with image/jpeg mime type : attachment appears.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 133580 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verifying dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.