Closed Bug 1389554 Opened 3 years ago Closed 3 years ago

Remove the dropdown icon (triangle) from the URL bar when something is being typed

Categories

(Firefox :: Address Bar, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: abenson, Assigned: adw)

References

()

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

The dropdown arrow in the URL bar is used to show a list of top sites. This isn't useful when something is being typed into the field because a) clicking on it makes the suggestions list go away and b) bringing the list back shows top sites and not suggestions for what you're typing. We should remove the dropdown affordance and only show the "Go" button (right arrow icon).

More details can be found in this spec: https://mozilla.invisionapp.com/share/94CLGV8GN#/243839921_Explainer_-_URL_Bar_Icon_Placement
Component: Menus → Location Bar
Whiteboard: [photon-structure] → [photon-structure] [triage]
Priority: -- → P4
Whiteboard: [photon-structure] [triage] → [reserve-photon-structure]
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 57.2 - Aug 29
Flags: qe-verify?
Priority: P4 → P1
All the code that updates the urlbar value is a bit of a tangle, but this seems to be all that's required.  On input, set a "usertyping" attribute, and when the value is set programmatically via URLBarSetURI, remove the attribute.  Note that URLBarSetURI is called on handleRevert, so handleRevert does not also need to remove the attribute.
Iteration: 57.2 - Aug 29 → 57.3 - Sep 19
Comment on attachment 8902049 [details]
Bug 1389554 - Remove the dropdown icon (triangle) from the URL bar when something is being typed.

https://reviewboard.mozilla.org/r/173460/#review179466

It looks ok, though there is a case that is a bit underspecified and I'm not sure if it's handled properly, and it's the case when the user cancels all the text. For example type "moz" change you mind and backspace to an empty string, try to open the panel.. no arrow. At this point focus content and focus again the hover the location bar, still no arrow.
I assume it could be handled checking the input value in onInput, and setting the attribute only if it's not an empty string, though as I said it's underspecified atm.
r=me with that clarified with UX, I'm available if the patch ends up being more complex, but I suspect it's just matter of a simple conditional check.
(note: the patch is bitrotted)
Attachment #8902049 - Flags: review?(mak77) → review+
s/focus again the hover/focus again OR hover/
Aaron, could you please answer:

(In reply to Marco Bonardo [::mak] from comment #4)
> It looks ok, though there is a case that is a bit underspecified and I'm not
> sure if it's handled properly, and it's the case when the user cancels all
> the text. For example type "moz" change you mind and backspace to an empty
> string, try to open the panel.. no arrow. At this point focus content and
> focus again the hover the location bar, still no arrow.

I would think that the user is still typing at this point, so we shouldn't show the arrow.  The user can press Esc to cancel the typing to show the arrow, and in fact that's what happens with the patch.
Flags: needinfo?(abenson)
The arrow should show if you've backed out your text since that could indicate a desire to "reset the field". It would also help to indicate that they could press the keyboard down-arrow to show the dropdown.
Flags: needinfo?(abenson)
Updated to show the arrow when the field is empty.
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/043653ff7779
Remove the dropdown icon (triangle) from the URL bar when something is being typed. r=mak
https://hg.mozilla.org/mozilla-central/rev/043653ff7779
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Depends on: 1396205
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
I have verified that the issue mentioned in comment 0 is no longer reproducbile with Firefox 57.0b7 (BuildId:20171009192146) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.

The dropdown icon (triangle) is no longer displayed while typing something in the URL bar.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.