With the native titlebar, caption buttons are vertically misaligned in maximized windows (Win 10)

VERIFIED FIXED

Status

()

Core
Widget: Win32
VERIFIED FIXED
3 months ago
17 days ago

People

(Reporter: Eddward, Unassigned)

Tracking

(Blocks: 1 bug, {ux-consistency})

unspecified
x86
Windows 10
ux-consistency
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: fixed by bug 1366405)

Attachments

(3 attachments)

(Reporter)

Description

3 months ago
Created attachment 8896377 [details]
Caption Buttons.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170810100255

Steps to reproduce:

1. Navigate to http://www.popuptest.com/goodpopups.html and click on a Good PopUp #1 link
2. Maximize pop-up window



Actual results:

See Caption buttons as not positioned correctly.


Expected results:

Caption buttons are following default Windows behaviour.
See attachment. 
I think this is a long term bug.
(Reporter)

Updated

3 months ago
Has STR: --- → yes
Component: Untriaged → Theme

Comment 1

3 months ago
(In reply to Eddward from comment #0)
> Caption buttons are following default Windows behaviour.
> See attachment. 
> I think this is a long term bug.

Can you explain what you mean by this?
Flags: needinfo?(Eddwardiq)
Whiteboard: [photon-visual][triage]
(Reporter)

Comment 2

3 months ago
Not sure what exactly you need to explain.
1. Expected behavior is that the buttons will be positioned correctly as in the other maximized win32 windows.
2. Long term bug because is not present only in the Nightly, but also in every Firefox since version 50 at least.
Flags: needinfo?(Eddwardiq)

Comment 3

3 months ago
(In reply to Eddward from comment #2)
> 2. Long term bug because is not present only in the Nightly, but also in
> every Firefox since version 50 at least.

Were there versions that didn't have this bug?
(Reporter)

Comment 4

3 months ago
I don't have an answer on this. Is possible that there aren't, but it is a minor, but still (in my opinion)a valid bug.
(Reporter)

Comment 5

3 months ago
It seems to be Windows 10 regression only, or at least there is no such problem on Windows 7 Aero or Classic theme. Verified with Firefox 52. 
Basically, I think the root cause is that caption buttons on Windows 10 have different shape in windowed mode and different in maximized mode and Firefox is painting pop-up caption buttons in both modes in the same shape.

Comment 6

3 months ago
Is this improved on today's nightly after bug 1375335?
Flags: needinfo?(Eddwardiq)
(Reporter)

Comment 7

3 months ago
Checking on 57.0a1 (2017-08-14) (64-bit). Still the same, so unfortunately no.
Flags: needinfo?(Eddwardiq)

Comment 8

3 months ago
(In reply to Eddward from comment #7)
> Checking on 57.0a1 (2017-08-14) (64-bit). Still the same, so unfortunately
> no.

That's yesterday's nightly, it wouldn't have the fix from bug 1375335. Today's will, but might not be available yet.
Flags: needinfo?(Eddwardiq)
(Reporter)

Comment 9

3 months ago
Ok tested on latest mozilla-central build.
Built from https://hg.mozilla.org/mozilla-central/rev/564e82f0f289af976da01c2d50507017bbc152b5
And still the same. No change.
Flags: needinfo?(Eddwardiq)

Updated

3 months ago
Flags: qe-verify+
Priority: -- → P4
QA Contact: ovidiu.boca
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]

Updated

3 months ago
Blocks: 1325171
(Reporter)

Updated

3 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-consistency
OS: Unspecified → Windows 10
Hardware: Unspecified → x86
(Reporter)

Comment 10

2 months ago
Actually this is also affecting the main Firefox window in maximized state with Titlebar enabled. See new attachment.
(Reporter)

Comment 11

2 months ago
Created attachment 8907052 [details]
Firefox window with titlebar enabled.png

Updated

2 months ago
Component: Theme → Widget: Win32
Product: Firefox → Core
Summary: Caption buttons are not rendered properly for maximized pop-up windows (Win 10) → With the native titlebar, caption buttons are vertically misaligned in maximized windows (Win 10)

Updated

2 months ago
No longer blocks: 1325171
Priority: P4 → --
QA Contact: ovidiu.boca
Whiteboard: [reserve-photon-visual]
(Reporter)

Updated

2 months ago
Blocks: 1077146

Updated

2 months ago
Depends on: 1366405
(Reporter)

Comment 12

2 months ago
Created attachment 8913191 [details]
fixed.png
(Reporter)

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Whiteboard: fixed by bug 1366405

Updated

2 months ago
status-firefox57: --- → fixed

Comment 13

17 days ago
Verified as fixed on Windows 10 x64 Fx 57.0b14 and 58.0a1.

Updated

17 days ago
status-firefox57: fixed → verified
status-firefox58: fixed → verified

Updated

17 days ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.