"Changed in the last [ ] days" confusing

RESOLVED DUPLICATE of bug 37749

Status

()

P3
normal
RESOLVED DUPLICATE of bug 37749
17 years ago
6 years ago

People

(Reporter: 3.14, Assigned: endico)

Tracking

Details

(Reporter)

Description

17 years ago
Sorry, I am not sure if "Query/Bug List" or "User Interface".

The query field "Changed in the last [ ] days" is confusing.
http://bugzilla.mozilla.org/queryhelp.cgi explains "Lets you specify how many
days ago - at maximum - a bug could have changed state."

1) It should say so, e.g.: "Changed status in the last [ ] days"

2) It is not obvious if bug creation is considered a change of status.

Further, people might think, that this field goes together with "Where the
field(s) [fields] changed to [text]", e.g., you might want to search for all
bugs which were created within 5 days and are UNCOFIRMED.

So it would also be nice to allow for something like now-4days.

pi
I'm not sure, but I think it's not just changes of bug_status. It's any changes,
isn't it? You are talking about the &changedin=2 parameter to buglist.cgi, and
it is translated to (to_days(now()) - to_days(bugs.delta_ts)) in buglist.cgi.
But I'm not sure what this means exactly.

Comment 2

17 years ago
Using delta_ts means that any changes (including adding comments etc.) matter. 
I think it's a good idea to change the string, but finding the correct wording 
is hard. "Touched in the last [ ] days" is my best shot so far, but this is not 
perfect either. 

I've heard people say that adding a comment (for example) doesn't sound 
like "changing the bug" - though it still updates delta_ts and thus counts as 
an update. I wonder if the "touch" thing is any better.

The context for this string changes a bit when changes in bug 98707 are taken 
into use, since the query page is redesigned in that templatisation (IIRC?). 
Any wording possible chosen should be carefully considered in the context of 
the new layout.
(Reporter)

Comment 3

17 years ago
According to Jouni's explanation, the help needs to be fixed. This can be a more
detailled explanation. I like your wording with "touched".

pi
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18

Comment 4

16 years ago
What about "updated in the last n days"?
The UI has been simplified by the fixing of bug 37749, and I believe this bug
goes away. You can see the new UI at attachment 117727 [details]. For the relative dates
stuff, see bug 149246.

*** This bug has been marked as a duplicate of 37749 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.