All users were logged out of Bugzilla on October 13th, 2018

Bookmark Menu object on the customize screen needs to be renamed "Bookmarks Menu"

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: bbell, Assigned: Gijs)

Tracking

57 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [reserve-photon-structure][photon-l10n-risk])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
This name change is necessary because The Bookmark Menu is referenced as the "Bookmark Menu" in the Library where we offer users the option to "Open Bookmark Menu," and as a destination users can save bookmarks to in the save dialog where users can "Save to Bookmark Menu." However, you can't find a "Bookmark Menu" under customize, because it's labeled "Bookmarks."
(Reporter)

Updated

a year ago
Whiteboard: [photon-structure]
(Reporter)

Comment 1

a year ago
Created attachment 8896440 [details]
detail.png

Screenshot of what needs to be renamed.
(Reporter)

Updated

a year ago
Component: Menus → Bookmarks & History
(Reporter)

Updated

a year ago
Component: Bookmarks & History → Menus
(Reporter)

Updated

a year ago
Summary: Bookmark Menu object on the customize screen needs to be renamed "Bookmark Menu" → Bookmark Menu object on the customize screen needs to be renamed "Bookmarks Menu"
(Reporter)

Comment 2

a year ago
(In reply to bbell from comment #0)
> This name change is necessary because The Bookmark Menu is referenced as the
> "Bookmark Menu" in the Library where we offer users the option to "Open
> Bookmark Menu," and as a destination users can save bookmarks to in the save
> dialog where users can "Save to Bookmark Menu." However, you can't find a
> "Bookmark Menu" under customize, because it's labeled "Bookmarks."

"Bookmarks Menu" (plural) should be the label.
Whiteboard: [photon-structure] → [photon-structure] [triage]
Priority: -- → P4
Whiteboard: [photon-structure] [triage] → [reserve-photon-structure]
(Assignee)

Updated

a year ago
Whiteboard: [reserve-photon-structure] → [reserve-photon-structure][photon-l10n-risk]
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 5

a year ago
Taking this because of the strings involved.

One question I have here: when you put this button in the overflow panel (either pin it or when it appears there because there's no space on the toolbar), it will show the same bookmarks view as the library does (same items/content, same title).

There is also normally only 1 label for the button that gets used both in customize mode and in the panel. The labeling situation right now is:

palette: "Bookmarks"
panel: "Bookmarks"
title of the subview in panel: "Bookmarks"
title of the subview in library panel: "Bookmarks"


The situation after the patches I've just attached is:

palette: "Bookmarks Menu"
panel: "Bookmarks Menu"
title of the subview in panel: "Bookmarks"
title of the subview in library panel: "Bookmarks"


This is a bit confusing because you'd expect the thing in the panel to show you the "bookmarks menu" and it doesn't (though it will if you move it to any of the toolbars)

In principle, I could write code to make the label for the customize mode palette and the panel different, so it changes label when you move it between these items, but that also seems confusing.

Really, I don't know how to weigh this inconsistency with the one from comment #0. I think we're a bit out of time to implement a separate bookmarks menu view for the bookmarks menu button to use when it's in the overflow panel... (ie that opens any folders as subviews or by opening the library, the latter being what we did pre-photon... I guess we could try to resurrect that code from hg history... but it sounds hairy.)

Bryan, what would you like to do? Take this patch, keep the status quo, or something else?
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 57.2 - Aug 29
Flags: needinfo?(bbell)
Flags: qe-verify?
Priority: P4 → P1

Comment 6

a year ago
mozreview-review
Comment on attachment 8900707 [details]
Bug 1389625 - change bookmarks menu button label,

https://reviewboard.mozilla.org/r/172154/#review177676
Attachment #8900707 - Flags: review?(adw) → review+

Comment 7

a year ago
mozreview-review
Comment on attachment 8900708 [details]
Bug 1389625 - clean up subview headers now that we use the title of the view instead,

https://reviewboard.mozilla.org/r/172156/#review177678
Attachment #8900708 - Flags: review?(adw) → review+
(Assignee)

Comment 8

a year ago
Discussed with Bryan, we're gonna go ahead with the rename.
Flags: needinfo?(bbell)

Comment 9

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1707066b3257
change bookmarks menu button label, r=adw
https://hg.mozilla.org/integration/autoland/rev/266a47a36a77
clean up subview headers now that we use the title of the view instead, r=adw
https://hg.mozilla.org/mozilla-central/rev/1707066b3257
https://hg.mozilla.org/mozilla-central/rev/266a47a36a77
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Comment 11

a year ago
I have reproduced this bug with Nightly 57.0a1 (2017-08-11) on Windows 8.1, 64 Bit!

This bug's fix is verified on Latest Nightly 57.0a1

Build ID : 20170830100404
User Agent : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170830]
Status: RESOLVED → VERIFIED
Flags: qe-verify?
You need to log in before you can comment on or make changes to this bug.