runtime.getBrowserInfo() expose beta version build number

UNCONFIRMED
Unassigned

Status

P5
normal
UNCONFIRMED
a year ago
5 days ago

People

(Reporter: ke5trel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Version values returned by runtime.getBrowserInfo():

> Nightly: 57.0a1
> Developer Edition: 56.0
> Beta: 56.0
> Release: 55.0

Beta version values lack the 'b' component (56.0b1) making them indistinguishable from release versions.
(Reporter)

Updated

a year ago
Blocks: 1268399
This is how version numbers are handled, but bug 1386076 should meet your needs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1386076
(Reporter)

Comment 2

a year ago
I want to notify the user when the beta build number changes in a format that is familiar to the user. It looks like this would require AppConstants.MOZ_APP_VERSION_DISPLAY to be exposed.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: runtime.getBrowserInfo() does not identify beta versions → runtime.getBrowserInfo() expose beta version build number

Comment 3

a year ago
I created bug 1386076 and yeah, the beta version number is a thing I need too, by the same reasons given in that bug.

Updated

a year ago
Priority: -- → P5

Comment 4

a year ago
I can add it as part of the patch for bug 1386076, or with other patch here.

Is it then Ok to change to AppConstants.MOZ_APP_VERSION_DISPLAY as the value returned for the version number by runtime.getBrowserInfo, instead of the current implementation? I think that numbers for beta builds will be the only affected by this.

Updated

2 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.