Mozilla crashes while loading new page when flash context menu is open

VERIFIED DUPLICATE of bug 87707

Status

()

Core
Plug-ins
P3
major
VERIFIED DUPLICATE of bug 87707
16 years ago
16 years ago

People

(Reporter: Rene Pronk, Assigned: av (gone))

Tracking

Trunk
mozilla1.1beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

RC1 crashes when you press on a link and quickly click right on a flash banner.
If the menu shows before the new page is loaded, wait until the new page is
loaded. The menu stays on top (even though the plugin doesn't exist anymore).
Clicking anywhere in the menu will crash Mozilla.
(see also TB5441145Z and TB5441439W)

Reproducible: Always
Steps to Reproduce:
1. Load page with flash banner
2. Click on any link
3. Quickly right click on the flash banner
4. Wait until the page is loaded
5. Click in the menu
6. Boom!

Actual Results:  Mozilla crashes.

Expected Results:  Mozilla crashes.
expected: Mozilla crashes? - then all is ok, or? :)

Comment 2

16 years ago
Well...

With a realease candidate, I guess crashes is just to be expected. I will try 
to check it though...

Comment 3

16 years ago
http://www.webwereld.nl works all fine for me. Tested it with 2002041903, so 
you might try a newer build to check if you still encounter this bug. 

Comment 4

16 years ago
o.k., got finally the browser crashing, rc01, Linux BuildID 2002041711
You've got to play around with the flash-banners: right-click them and go to
another link, but this is not always reproducible. When the flash-context-menu
does not disappear teh page is loaded, you're on the right way ;-)
Talkback-data: TB5448241Z

Comment 5

16 years ago
SAme here.
crashing with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
You can try any news article in www.zdnet.com to reproduce,
like http://zdnet.com.com/2100-1105-887354.html
(Reporter)

Comment 6

16 years ago
Still exists with latest build (2002041903) on Win2K.
See TB5465999E.

Comment 7

16 years ago
after much clicking and jumping around from links to pages and plug-ins, I 
finally got this to crash, but it took a lot of effort to get it to finally get 
to that state. Looking at the stack trace (Incident ID 5482700), it looks as 
though it is the system and not the application:

Stack Trace

0x05f0766c 
0x0068fbac 
0x05f05b9d 
KERNEL32.DLL + 0x363b (0xbff7363b) 
KERNEL32.DLL + 0x24407 (0xbff94407) 
0x00688c16 
Assignee: beppe → av
Severity: critical → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → mozilla1.1beta
(Reporter)

Comment 8

16 years ago
Then you probably have a fast internet connection. Try it with a modem, it works
almost every time for me.

Although I have no knowledge of the Mozilla internals, the menu seems to be
owned by the flash plugin, which would suggest that either this is a flash bug
because flash doesn't destroy its resources properly or a Mozilla bug because
Mozilla doesn't close the plugin properly.

(A somewhat dirty hack could perhaps be sending yourself an Esc key message
before creating a new DOM.)

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 87707 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.