Closed Bug 1389771 Opened 2 years ago Closed 2 years ago

For 'Edit Draft' command, allow Shift key to override composition format/mode

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 57.0

People

(Reporter: bugzilla2007, Assigned: jorgk-bmo)

References

(Depends on 1 open bug)

Details

(4 keywords)

+++ This bug was initially created as a clone of Bug #731688 +++

We allow Shift modifier key to toggle composing in opposite-of-default format (Plaintext vs. HTML) for virtually all ways of going into composition:
* Write, Reply, Forward, Edit as New Message (bug 731688) etc.
* message header buttons
* message menus, context menus, and app menus
So it's somewhat surprising in terms of ux-consistency that Shift modifier is ignored for the "Edit draft" command, which will always use the format of the original message. Changing the format of an existing draft is a legitimate use case, and it's pretty hard to do without this trick.

We agreed to do this as a followup to bug 1106412 (see bug 1106412, Comment 39). Btw WADA also offers extensive analysis on bug 1106412 of how to implement Shift, maybe we can use that for our current work here:
Jörg is currently implementing Shift for "Edit as New Message" in bug 731688, and he offered a code snippet in bug 1389083 comment 3.

STR

1) Hold Shift while choosing
- "Edit Draft Message" from Message Menu, or
- "Edit Draft Message" from App Menu, or
- "Edit Draft" from message Context Menu, or
- "Edit" button on draft notification bar
1a) starting out from a plaintext msg
1b) starting out from a HTML msg
* observe message format in composition window

2) For comparison:
Hold Shift while choosing any of the following commands from message (context) menu, app menu, or message header buttons:
- Write
- Reply to Sender Only
- Reply to All
- Reply to List
- Forward
* observe message format in composition window

Actual result

1) With or without Shift, message format == composition format/mode:
1a) plaintext composition (like original msg)
1b) HTML composition (like original msg)

2) For all other commands that open a composition window (reply, forward etc.), we respect the Shift modifier to trigger composing in opposite-of-default format

Expected result

1a) Shift when original draft msg is plaintext:
-> compose in opposite-of-default format (HTML, after upgrading)

1b) Shift when original draft msg is HTML:
-> compose in opposite-of-default format (plaintext; after downgrading)
Rephrase:

Expected result

1) Compose in opposite-of-default format (original draft message format != composition format/mode)
1a) HTML format/composition mode (after upgrading)
2b) plaintext format/composition mode (after downgrading)
(In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment #1)
> Rephrase:
> 
> Expected result
> 
> 1) Compose in opposite-of-default format (original draft message format !=
> composition format/mode)
> 1a) HTML format/composition mode (after upgrading)
> 2b) plaintext format/composition mode (after downgrading)

Obviously, that's
1b) plaintext format/composition mode (after downgrading)
(In reply to Thomas D. from bug 1389083 comment #30)
> Created attachment 8898633 [details] [diff] [review]
> Part1 - Frontend - WIP Patch V.3.1: (incl. tweak for cmd_editDraftMsg)
> Implement cmd_newMsgFromTemplate
> 
> Same as V.3, but I've added one line to tweak the frontend required for bug
> 1389771 (backend currently planned tbd by Jörg in bug 731688):
> 
> > <command id="cmd_editDraftMsg" oncommand="goDoCommand('cmd_editDraftMsg')"/>
> <command id="cmd_editDraftMsg" oncommand="MsgEditDraftMessage(event);"/>
> 
> Otherwise I had already made the frontend ready for Shift in bug 1106412.
Will be fixed in bug 731688.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731688
FIXED by bug 731688.

Per current summaries, and wrt statistics, this was an enhancement in its own right, which has been implemented (mostly) by Jörg in bug 731688 (with some preparatory work by me, see comment 3).

Followup: Bug 1392056 - Fix shift-click on "Edit" button in drafts folder
Assignee: nobody → jorgk
Severity: normal → enhancement
Depends on: 1392056
Resolution: DUPLICATE → FIXED
Target Milestone: --- → Thunderbird 57.0
You need to log in before you can comment on or make changes to this bug.