Intermittent netwerk/test/unit/test_bug650995.js | xpcshell return code: 139

RESOLVED DUPLICATE of bug 1399773

Status

()

Core
Networking
P3
normal
RESOLVED DUPLICATE of bug 1399773
10 months ago
6 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

10 months ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=122759797&repo=autoland

https://queue.taskcluster.net/v1/task/NaZ7lWWpQBqC9yvj-wPIZQ/runs/0/artifacts/public/logs/live_backing.log

[task 2017-08-12T15:08:48.330199Z] 15:08:48     INFO -  TEST-START | netwerk/test/unit/test_bug650995.js
[task 2017-08-12T15:08:56.386652Z] 15:08:56  WARNING -  TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_bug650995.js | xpcshell return code: 139
[task 2017-08-12T15:08:56.387422Z] 15:08:56     INFO -  TEST-INFO took 8057ms
[task 2017-08-12T15:08:56.388045Z] 15:08:56     INFO -  >>>>>>>
[task 2017-08-12T15:08:56.388132Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | xpcw: cd /storage/sdcard/tests/xpc/netwerk/test/unit
[task 2017-08-12T15:08:56.389071Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | xpcw: xpcshell -r /storage/sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/target.apk -m -s -e const _HEAD_JS_PATH = "/storage/sdcard/tests/xpc/head.js"; -e const _MOZINFO_JS_PATH = "/storage/sdcard/tests/xpc/p/mozinfo.json"; -e const _TESTING_MODULES_DIR = "/storage/sdcard/tests/xpc/m"; -f /storage/sdcard/tests/xpc/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/storage/sdcard/tests/xpc/netwerk/test/unit/head_channels.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache2.js"]; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_bug650995.js"]; -e const _TEST_NAME = "netwerk/test/unit/test_bug650995.js" -e _execute_test(); quit(0);
[task 2017-08-12T15:08:56.392062Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | [1115] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /home/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp, line 171
[task 2017-08-12T15:08:56.392139Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | Warning: MOZILLA_FIVE_HOME not set.
[task 2017-08-12T15:08:56.392251Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | [1115] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /home/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2866
[task 2017-08-12T15:08:56.392302Z] 15:08:56     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2017-08-12T15:08:56.392344Z] 15:08:56     INFO -  (xpcshell/head.js) | test pending (2)
[task 2017-08-12T15:08:56.392388Z] 15:08:56     INFO -  (xpcshell/head.js) | test pending (3)
[task 2017-08-12T15:08:56.392441Z] 15:08:56     INFO -  (xpcshell/head.js) | test MAIN run_test finished (3)
[task 2017-08-12T15:08:56.392488Z] 15:08:56     INFO -  running event loop
[task 2017-08-12T15:08:56.392576Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | JavaScript strict warning: test_bug650995.js, line 81: ReferenceError: assignment to undeclared variable cap
[task 2017-08-12T15:08:56.392632Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | Segmentation fault
[task 2017-08-12T15:08:56.392679Z] 15:08:56     INFO -  netwerk/test/unit/test_bug650995.js | 13
[task 2017-08-12T15:08:56.392712Z] 15:08:56     INFO -  <<<<<<<
[task 2017-08-12T15:08:56.876037Z] 15:08:56     INFO -  mozcrash Copy/paste: /home/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmp4RR9W4/4869656f-542d-c673-7046-0c67e1672464.dmp /home/worker/workspace/build/symbols
[task 2017-08-12T15:08:56.987426Z] 15:08:56     INFO -  mozcrash Saved minidump as /home/worker/workspace/build/blobber_upload_dir/4869656f-542d-c673-7046-0c67e1672464.dmp
[task 2017-08-12T15:08:56.993190Z] 15:08:56     INFO -  mozcrash Saved app info as /home/worker/workspace/build/blobber_upload_dir/4869656f-542d-c673-7046-0c67e1672464.extra
[task 2017-08-12T15:08:56.993281Z] 15:08:56  WARNING -  PROCESS-CRASH | netwerk/test/unit/test_bug650995.js | application crashed [@ libxul.so + 0x5903c]
[task 2017-08-12T15:08:56.993347Z] 15:08:56     INFO -  Crash dump filename: /tmp/tmp4RR9W4/4869656f-542d-c673-7046-0c67e1672464.dmp
[task 2017-08-12T15:08:56.993393Z] 15:08:56     INFO -  Operating system: Android
[task 2017-08-12T15:08:56.993454Z] 15:08:56     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l
[task 2017-08-12T15:08:56.993493Z] 15:08:56     INFO -  CPU: arm
[task 2017-08-12T15:08:56.993553Z] 15:08:56     INFO -       ARMv7 ARM Cortex-A8 features: swp,half,thumb,fastmult,vfpv2,edsp,neon,vfpv3
[task 2017-08-12T15:08:56.993592Z] 15:08:56     INFO -       1 CPU
[task 2017-08-12T15:08:56.993628Z] 15:08:56     INFO -  GPU: UNKNOWN
[task 2017-08-12T15:08:56.993670Z] 15:08:56     INFO -  Crash reason:  SIGSEGV
[task 2017-08-12T15:08:56.993708Z] 15:08:56     INFO -  Crash address: 0x0
[task 2017-08-12T15:08:56.993750Z] 15:08:56     INFO -  Process uptime: not available
[task 2017-08-12T15:08:56.993789Z] 15:08:56     INFO -  Thread 14 (crashed)
[task 2017-08-12T15:08:56.993831Z] 15:08:56     INFO -   0  libxul.so + 0x5903c
[task 2017-08-12T15:08:56.993897Z] 15:08:56     INFO -       r0 = 0x00000086    r1 = 0xe49c05a6    r2 = 0xe49c05a6    r3 = 0x00000000
[task 2017-08-12T15:08:56.993960Z] 15:08:56     INFO -       r4 = 0x45c0b530    r5 = 0x45c0b514    r6 = 0x529ff5b4    r7 = 0x45c0b500
[task 2017-08-12T15:08:56.994022Z] 15:08:56     INFO -       r8 = 0x529ff5b4    r9 = 0x434d7b54   r10 = 0x4305dff6   r12 = 0x00000003
[task 2017-08-12T15:08:56.994081Z] 15:08:56     INFO -       fp = 0x529ff5fc    sp = 0x529ff588    lr = 0x40715b43    pc = 0x4071703c
[task 2017-08-12T15:08:56.995471Z] 15:08:56     INFO -      Found by: given as instruction pointer in context
[task 2017-08-12T15:08:56.995522Z] 15:08:56     INFO -   1  libxul.so + 0x5add7
[task 2017-08-12T15:08:56.995580Z] 15:08:56     INFO -       sp = 0x529ff590    pc = 0x40718dd9
[task 2017-08-12T15:08:56.995633Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.995683Z] 15:08:56     INFO -   2  libxul.so + 0x70f53
[task 2017-08-12T15:08:56.995737Z] 15:08:56     INFO -       sp = 0x529ff5a0    pc = 0x4072ef55
[task 2017-08-12T15:08:56.995779Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.995827Z] 15:08:56     INFO -   3  libxul.so + 0x2997228
[task 2017-08-12T15:08:56.995876Z] 15:08:56     INFO -       sp = 0x529ff5a4    pc = 0x4305522a
[task 2017-08-12T15:08:56.995927Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.995977Z] 15:08:56     INFO -   4  libxul.so + 0x299fff4
[task 2017-08-12T15:08:56.996032Z] 15:08:56     INFO -       sp = 0x529ff5b8    pc = 0x4305dff6
[task 2017-08-12T15:08:56.996079Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.996119Z] 15:08:56     INFO -   5  libxul.so + 0x299fff4
[task 2017-08-12T15:08:56.996165Z] 15:08:56     INFO -       sp = 0x529ff5e4    pc = 0x4305dff6
[task 2017-08-12T15:08:56.996333Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.996562Z] 15:08:56     INFO -   6  libxul.so + 0x7109f
[task 2017-08-12T15:08:56.996801Z] 15:08:56     INFO -       sp = 0x529ff5f0    pc = 0x4072f0a1
[task 2017-08-12T15:08:56.997026Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.997280Z] 15:08:56     INFO -   7  libxul.so + 0x1be1f03
[task 2017-08-12T15:08:56.997512Z] 15:08:56     INFO -       sp = 0x529ff5f8    pc = 0x4229ff05
[task 2017-08-12T15:08:56.997740Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.997962Z] 15:08:56     INFO -   8  libxul.so + 0x2997228
[task 2017-08-12T15:08:56.998194Z] 15:08:56     INFO -       sp = 0x529ff604    pc = 0x4305522a
[task 2017-08-12T15:08:56.998443Z] 15:08:56     INFO -      Found by: stack scanning
[task 2017-08-12T15:08:56.998671Z] 15:08:56     INFO -   9  libxul.so + 0x1be2193
[task 2017-08-12T15:08:56.998902Z] 15:08:56     INFO -       sp = 0x529ff628    pc = 0x422a0195
[task 2017-08-12T15:08:56.999131Z] 15:08:56     INFO -      Found by: stack scanning

Comment 1

10 months ago
1 failures in 901 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-08-07&endday=2017-08-13&tree=all

Comment 2

10 months ago
2 failures in 949 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-08-14&endday=2017-08-20&tree=all

Updated

10 months ago
Depends on: 1392985

Updated

10 months ago
Whiteboard: [necko-backlog]

Comment 3

10 months ago
1 failures in 939 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-08-28&endday=2017-09-03&tree=all

Comment 4

9 months ago
3 failures in 924 pushes (0.003 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 3

Platform breakdown:
* android-4-3-armv7-api16: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-09-04&endday=2017-09-10&tree=all
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399773

Comment 8

9 months ago
1 failures in 1032 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-09-11&endday=2017-09-17&tree=all

Comment 9

7 months ago
2 failures in 849 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* try: 1
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api16: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-11-06&endday=2017-11-12&tree=all

Comment 10

7 months ago
1 failures in 744 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* try: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-11-20&endday=2017-11-26&tree=all

Comment 11

6 months ago
1 failures in 889 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1389807&startday=2017-12-04&endday=2017-12-10&tree=all
You need to log in before you can comment on or make changes to this bug.