Firefox 54 doesn't detect Firefox 55 update available

RESOLVED DUPLICATE of bug 1389506

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1389506
4 months ago
4 months ago

People

(Reporter: Dan Pernokis, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170809080026

Steps to reproduce:

I have updates set to Manual on all my machines (all PC Windows 7).
Under HELP, ABOUT I saw current version (54.0.1) and clicked CHECK FOR UPDATES as usual.


Actual results:

On Tower (main PC Windows 7 machine), running FF 54.0.1 at the time, the updates to FF 50.0 and 50.0.1 worked OK.

But on Laptop (also a PC Windows7  machine), still running FF 54.0.1, the update check says none are available when FF 50.0 and now  50.0.1 are in fact available.
Even after rebooting, the detection of update still fails.



Expected results:

Updates should work normally as they usually do.  I don't see any help or suggestions about this, other than instructions to run the standard Help/About/Check that I already did.
(Reporter)

Comment 1

4 months ago
Doh...   FF 50.0 and 50.0.1 should read 55.0 and 55.0.1.
I'm trying to update from FF 54 to FF 55.

Updated

4 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389506
Dan this should be fixed by now. FF 54.0.1 will find the update to the just released 55.0.2. According to bugzilla it was intentional that 54.0.1 did not update to 55.x on all systems. Please try and confirm if it is fixed for you, too.
(Reporter)

Comment 4

4 months ago
In a word, Yes -- I can confirm it works here.

I first updated my PC Windows 7 Tower from 55.0.1 to 55.0.2 -- it had been updated before the recall, I guess.
Then I was able to update the Laptop (also PC Win 7) from 54.0.1 to 55.0.2 with only one unrelated hiccup -- the partial update (DL 24.4 mb) would not take, so it required the full download (43.0 mb), which worked OK.  (I say unrelated because this happens often on the Laptop for some reason, and only rarely on the Tower.)
You need to log in before you can comment on or make changes to this bug.