Special characters in passwords (like #) don't work during account creation

RESOLVED INCOMPLETE

Status

Thunderbird
Untriaged
RESOLVED INCOMPLETE
11 months ago
11 months ago

People

(Reporter: chris anthony, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

Steps to reproduce:

Tried the account in several other email clients and webmail clients all worked


Actual results:

I have come across an interesting problem when setting up a new account in Thunderbird. The account I was trying to set up was a BT.com account. the password that the client had used contained a #. Whenever I tried to set up the account, it came back "user name or password incorrect". To ascertain that the password was correct I used the BT WebMail portal and it logged on successfully. I also tried Windows Live Mail and that functioned correctly.

The question is, is the # a restricted character in Thunderbird account passwords?


Expected results:

Account should have been created

Comment 1

11 months ago
Looks like this is an ancient old problem, see bug 312593.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312593

Comment 2

11 months ago
Sorry, bug 312593 is for international characters (unicode). "#" works for me in a password, but then, I didn't try account creation, I just changed an password of an existing account.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
See Also: → bug 765157
Summary: Symbols in passwords → Special characters in passwords (like #) don't work during account creation

Comment 3

11 months ago
Hmm, I tried account creation with Xy12345# and that worked.

Comment 4

11 months ago
Sorry, we didn't hear back from you, so closing at incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago11 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.