Status

Release Engineering
General Automation
RESOLVED INCOMPLETE
5 months ago
5 months ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
I am getting an error about an aborted transaction on try when pushing to try:

$ git push -f try
Bundling 4 changesets
Bundling 3 manifests
Bundling 1 files
remote: abort: abandoned transaction found!
remote: (run 'hg recover' to clean up transaction)
Traceback (most recent call last):
  File "/home/ehsan/moz/git-cinnabar/git-remote-hg", line 48, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/home/ehsan/moz/git-cinnabar/git-remote-hg", line 42, in main
    helper.run()
  File "/home/ehsan/moz/git-cinnabar/cinnabar/remote_helper.py", line 110, in run
    func(*args)
  File "/home/ehsan/moz/git-cinnabar/cinnabar/remote_helper.py", line 378, in push
    self._branchmap.names(), self._dry_run)
  File "/home/ehsan/moz/git-cinnabar/cinnabar/hg/__init__.py", line 674, in push
    reply = repo.unbundle(cg, repo_heads, '')
  File "/usr/local/lib/python2.7/dist-packages/mercurial/wireproto.py", line 443, in unbundle
    ret = bundle2.getunbundler(self.ui, stream)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/bundle2.py", line 660, in getunbundler
    magicstring = changegroup.readexactly(fp, 4)
  File "/usr/local/lib/python2.7/dist-packages/mercurial/changegroup.py", line 42, in readexactly
    % (len(s), n))
mercurial.error.Abort: stream ended unexpectedly (got 0 bytes, expected 4)
error: failed to push some refs to 'hg::ssh://hg.mozilla.org/try'
(Reporter)

Comment 1

5 months ago
I really wanted to push my patch to try tonight so I cloned an hg repo and tried pushing from there just to make sure that this isn't caused by cinnabar.  Now I get:

$ hg push -f ssh://hg.mozilla.org/try
pushing to ssh://hg.mozilla.org/try
no revisions specified to push; using . to avoid pushing multiple heads
searching for changes
remote: waiting for lock on working directory of /repo/hg/mozilla/try held by process '20939' on host 'hgssh4.dmz.scl3.mozilla.com/effffffc'
^[[A
remote: abort: working directory of /repo/hg/mozilla/try: timed out waiting for lock held by 'hgssh4.dmz.scl3.mozilla.com/effffffc:22313'
abort: stream ended unexpectedly (got 0 bytes, expected 4)

And the push process is hanging for several minutes before timing out.
(Reporter)

Comment 2

5 months ago
This works now.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.