"Restart to update" panel banner UI description is deceptive for private windows (implies they will be restored, but that isn't the case)

RESOLVED FIXED in Firefox 57

Status

()

defect
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: waqas20, Assigned: rstrong)

Tracking

55 Branch
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

No particular steps, just the "Restart to update Firefox" panel banner UI popped up without me doing anything. Screenshot attached.


Actual results:

The UI had the message "After a quick restart, Firefox will restore all your open tabs and windows.". This is deceptive as the focused window was a private browsing window, and my assumption is that private windows would not be restored. I chose not to test this theory as I do not want to lose that private window accidentally at this time.


Expected results:

If the user has private windows open, the messaging should be explicit about whether private windows would be restored or not.
Component: Untriaged → Toolbars and Customization
Blocks: 893505
Component: Toolbars and Customization → Application Update
Product: Firefox → Toolkit
Summary: "Restart to update" panel banner UI description is deceptive for private tabs → "Restart to update" panel banner UI description is deceptive for private windows (implies they will be restored, but that isn't the case)
Bram, can I get your input on this? Thanks
Flags: needinfo?(bram)
Sorry for the overdue reply, as I’ve just returned from PTO on Monday.

There are two possible solutions here:

1. If on Private Window, don’t show this dialogue
  * Will this be problematic? For example, what if I set Firefox to always use Private Browsing mode?

2. If on Private Window, modify the message so it says something like this:

> Restart to update Firefox.
>
> Firefox will close all your Private Tabs and Windows.
>
> [Not Now] [Close and Restart]


What do you think?
Flags: needinfo?(bram) → needinfo?(robert.strong.bugs)
It is possible to have both private and regular tabs and windows. The regular tabs and windows will be restored and the private ones will not. Changing the strings as you suggested would have the opposite issue of restoring the regular tabs and windows while only informing the client that private tabs and windows won't be restored. This UI can also be shown on a regular window when there are other windows using private browsing. It would be better to either have a more generic message that avoids speaking of restoring tabs and windows if we think most clients already understand this or barring that a more specific message that covers both. I haven't thought of a more generic message but a more specific message might be.

After a quick restart, Firefox will restore all your open tabs and windows that are not private.
Flags: needinfo?(robert.strong.bugs) → needinfo?(bram)
That’s a very important concern, and I agree that a more generic message will avoid the problem.

Does this slight modification make it clearer?

> After a quick restart, Firefox will restore all your open tabs and windows that are not in Private Browsing mode.
>
> [Not Now] [Restart and Restore]

If so, then I think that we’re ready to ship it.
Flags: needinfo?(bram) → needinfo?(robert.strong.bugs)
That works for me.
Flags: needinfo?(robert.strong.bugs)
Posted patch patch rev1Splinter Review
Assignee: nobody → robert.strong.bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8904774 - Flags: review?(dothayer)
Attachment #8904774 - Flags: review?(dothayer) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/76e8870c843e
make it clear in the update doorhanger text that private browser windows and tabs are not restored. r=dothayer
https://hg.mozilla.org/mozilla-central/rev/76e8870c843e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1483386
You need to log in before you can comment on or make changes to this bug.