Closed Bug 13901 Opened 20 years ago Closed 20 years ago

Sidebar open/closed state isn't saved

Categories

(SeaMonkey :: Sidebar, defect, P1, blocker)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mikepinkerton, Assigned: eric)

References

Details

Create a new profile. The sidebar is initially open.
Close it. Quit and relaunch.

Sidebar is still open on relaunch.
Status: NEW → ASSIGNED
Priority: P3 → P1
Hardware: Macintosh → All
Target Milestone: M11
Ok, I broke that when I switched to the new layout. I will check in a fix
shortly. In the meantime, you can completely hide the sidebar using the "View /
Sidebar" menu option. That should persist between runs.
*** Bug 14150 has been marked as a duplicate of this bug. ***
Assignee: slamm → evaughan
Status: ASSIGNED → NEW
The splitter does not properly initialize when its state is set to collapsed.
Reassigning to evaughan.
Escalating to blocker.
This is the number one complaint about the sidebar.
I checked out the box code and there is no support for adding/removing splitter
siblings. What happens in the sidebar case is that the box containing the
sidebar gets added after the splitter that is supposed to collapse it. The
splitter has no way of knowing a new sibling has been added.
Severity: normal → blocker
OS: Mac System 8.5 → All
Blocks: 8642
Status: NEW → ASSIGNED
This involved adding a new interface to box and changing the way splitters talk
with boxes.
*** Bug 16372 has been marked as a duplicate of this bug. ***
Target Milestone: M11 → M12
m12
*** Bug 19208 has been marked as a duplicate of this bug. ***
*** Bug 19154 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
verified fixed on 11/19. Note: this is only on initial window. On subsequent
windows the sidebar still comes up open. See bug 16516.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.