Port bug 1375335 to TB [Menu bar is too high]

RESOLVED FIXED in Thunderbird 57.0

Status

Thunderbird
Theme
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 57.0
All
Windows

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 months ago
Bug 1375335 makes some changes in the item calculations for the titlebar/tabbar elements. We should change our code to be in sync with them.
(Assignee)

Comment 1

4 months ago
Created attachment 8896949 [details] [diff] [review]
controlCalculation.patch

This is a port of https://hg.mozilla.org/integration/autoland/rev/37ba4f932f57 which lands soon.

This is to test only with drawintitlebar=true

Without patch you see, when you have maximised the window and change to the normal window size, for a very short time a white line above the tabs toolbar and then all is jumping up 1px. With patch it doesn't happen.

We are differing in the .titlebar-button padding. We use 9px top/bottom-padding instead of 8px to let the window controls not jump in the height when showing/hiding the menu. This is also caused because of our different implementation with two toolboxes for the menubar/tabbar and the main toolbar. FX uses a margin-bottom: -1px on the tabbar we needed to solve differently because of our separated toolboxes. That's also the cause why I needed to make the tabbbar height even (30px).

Also for Win7 Aero we are different with the position of the menubar with below the tabs. Because of this, we can now remove a lot of code which added/removed margins.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8896949 - Flags: review?(jorgk)

Comment 2

4 months ago
That's the one that landed: https://hg.mozilla.org/mozilla-central/rev/fdc6247f8fca
(Assignee)

Comment 3

4 months ago
Only the test changed to the one I noted.

Comment 4

4 months ago
Comment on attachment 8896949 [details] [diff] [review]
controlCalculation.patch

I applied the patch and don't see any difference in looks on Windows 10.

(In reply to Richard Marti (:Paenglab) from comment #1)
> Without patch you see, when you have maximised the window and change to the
> normal window size, for a very short time a white line above the tabs
> toolbar and then all is jumping up 1px. With patch it doesn't happen.
It still happens. While before the "very short time" was quite noticeable, I measured 100 ms, it's now down to 40 ms. Maybe you don't see it any more on an opt build. On the Daily opt build without this patch, I don't see it.
Attachment #8896949 - Flags: review?(jorgk) → review+
(Assignee)

Updated

4 months ago
Keywords: checkin-needed

Comment 5

4 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/89fef90ea52f
Port bug 1375335 to TB [Fix window control height calculation on Windows 10]. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

4 months ago
Target Milestone: --- → Thunderbird 57.0
You need to log in before you can comment on or make changes to this bug.