"Add new rule" button does nothing (inserts empty <style type="text/css"></style> instead)

RESOLVED INVALID

Status

RESOLVED INVALID
a year ago
4 months ago

People

(Reporter: nachtigall, Unassigned)

Tracking

56 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:

1. Open DevTools' Inspector
2. On most pages, e.g. https://www.google.de/?gws_rd=ssl or https://www.mozilla.org/en-US/ the "Add new rule" button does not work

ER: A new CSS rule can be added

AR: An empty <style type="text/css"></style> is added just above the closing </html> tag.

It's like this on most pages. On some pages (I could not see a real pattern here) it works, e.g. on about:home
I tested with both of the URLs provided in step 2, with Firefox 57, on Windows 10, and it worked fine for me.
The new CSS rule is added in the rule-view, with a default selector, in edit mode (the <style></style> node is also added at the end of the <body>, as you said, which is expected).

When this doesn't work, can you please provide a screenshot of the rule-view? Also, if you open the browser console (ctrl+shift+J) when it happens, is there any errors in there that could be helpful to us?
Flags: needinfo?(nachtigall)
(Reporter)

Comment 2

a year ago
Hmm, can't reproduce either now. Probably fixed by something else in the meantime. Closing.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nachtigall)
Resolution: --- → INVALID

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.