Crash in core::result::unwrap_failed<T> | webrender::renderer::LazilyCompiledShader::bind

RESOLVED FIXED in Firefox 57

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: sotaro)

Tracking

(Blocks 1 bug, {crash, regression})

57 Branch
mozilla57
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 disabled, firefox57 fixed)

Details

(crash signature)

Attachments

(1 attachment, 5 obsolete attachments)

This bug was filed from the Socorro interface and is 
report bp-87d7e75e-2a2d-43e0-b914-b66820170813.
=============================================================

Seen while looking at nightly crashes - crashes started using 20170812100345: http://bit.ly/2wJ0yQD

Bug 1385003 is in that time frame.
We really need some way to get the panic messages into the crash report.
Version: Trunk → 57 Branch
Assignee: nobody → sotaro.ikeda.g
Depends on: 1394338
Posted patch wip (obsolete) — Splinter Review
Posted patch wip (obsolete) — Splinter Review
Attachment #8902169 - Attachment is obsolete: true
Posted patch wip patch (obsolete) — Splinter Review
Attachment #8902496 - Attachment is obsolete: true
Attachment #8903031 - Attachment is obsolete: true
Attachment #8903053 - Attachment is obsolete: true
Attachment #8903055 - Attachment is obsolete: true
Attachment #8903395 - Flags: review?(bugmail)
Comment on attachment 8903395 [details] [diff] [review]
patch - Add render() error handling to gecko

Review of attachment 8903395 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/ipc/GPUProcessManager.cpp
@@ +447,5 @@
>        "Failed to make render context current",
>        NS_LITERAL_CSTRING("FEATURE_FAILURE_WEBRENDER_MAKE_CURRENT"));
> +  } else if (aError == wr::WebRenderError::RENDER) {
> +    gfx::gfxConfig::GetFeature(gfx::Feature::WEBRENDER).ForceDisable(
> +      gfx::FeatureStatus::Unavailable,

This should probably be FeatureStatus::Failed or FeatureStatus::Broken, since we tried to enable but then it failed later.

::: gfx/webrender_bindings/src/bindings.rs
@@ +449,5 @@
> +                println!(" Failed to render: {:?}", e);
> +                let msg = CString::new(format!("wr_renderer_render: {:?}", e)).unwrap();
> +                unsafe {
> +                    gfx_critical_note(msg.as_ptr());
> +               }

nit: indentation
Attachment #8903395 - Flags: review?(bugmail) → review+
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ca9c4d3658c
Add render() error handling to gecko. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/5ca9c4d3658c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Blocks: 1397770
Blocks: 1397831
Blocks: 1398241
See Also: → 1408514
You need to log in before you can comment on or make changes to this bug.