Closed Bug 1390176 Opened 4 years ago Closed 4 years ago

Increase console logLimit

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(firefox57 fixed)

RESOLVED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox57 --- fixed

People

(Reporter: bgrins, Assigned: bgrins)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-console-html])

Attachments

(2 files)

As a way to make Bug 1386289 less likely, we should bump up the default log limit from 1000
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [console-html] → [reserve-console-html]
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Iteration: --- → 57.1 - Aug 15
Priority: P3 → P1
Iteration: 57.1 - Aug 15 → 57.2 - Aug 29
Comment on attachment 8897040 [details]
Bug 1390176 - Fix the jsterm stub in test_render_perf;

https://reviewboard.mozilla.org/r/168324/#review174372

::: devtools/client/webconsole/new-console-output/test/chrome/test_render_perf.html:22
(Diff revision 1)
>  
>  // To analyze the profile results:
>  // > ./mach mochitest test_render_perf.html
>  // Then open https://perf-html.io and drag the json file printed at the end of this test
>  
>  const NUM_MESSAGES = 4000;

Should we change that as well (to 14000) ?
This way we still test how much it cost to have more messages than the console displays.
Attachment #8897040 - Flags: review?(nchevobbe) → review+
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #4)
> Comment on attachment 8897040 [details]
> Bug 1390176 - Fix the jsterm stub in test_render_perf;
> 
> https://reviewboard.mozilla.org/r/168324/#review174372
> 
> :::
> devtools/client/webconsole/new-console-output/test/chrome/test_render_perf.
> html:22
> (Diff revision 1)
> >  
> >  // To analyze the profile results:
> >  // > ./mach mochitest test_render_perf.html
> >  // Then open https://perf-html.io and drag the json file printed at the end of this test
> >  
> >  const NUM_MESSAGES = 4000;
> 
> Should we change that as well (to 14000) ?
> This way we still test how much it cost to have more messages than the
> console displays.

I tried this originally, but the slowness is relatively linear so we get similar information with the smaller number and the test finishes much more quickly.
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #3)
> Comment on attachment 8897041 [details]
> Bug 1390176 - Increase console logLimit;
> 
> https://reviewboard.mozilla.org/r/168330/#review174368
> 
> Should we change it in
> http://searchfox.org/mozilla-central/rev/
> 13148faaa91a1c823a7d68563d9995480e714979/devtools/client/webconsole/local-
> dev/index.js#31 too ?

Yes, good catch
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17f391c7458c
Fix the jsterm stub in test_render_perf;r=nchevobbe
https://hg.mozilla.org/integration/autoland/rev/9a32af020333
Increase console logLimit;r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/17f391c7458c
https://hg.mozilla.org/mozilla-central/rev/9a32af020333
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Product: Firefox → DevTools
Duplicate of this bug: 986737
You need to log in before you can comment on or make changes to this bug.