Closed Bug 1390177 Opened 4 years ago Closed 4 years ago

Remove background change on hover

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(firefox57 fixed)

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(3 files)

When you hover a message in the console, the background turns into a light blue background. Now, if you have an expanded object which takes a certain height of the console, the hover background is not helpful at all and makes it slightly harder to parse the object.

The background should be removed in favor of something else.
Attached image left-border on hover
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: -- → P1
Duplicate of this bug: 1390800
Comment on attachment 8897762 [details]
Bug 1390177 - Change message hover style. .

https://reviewboard.mozilla.org/r/168328/#review174528

::: devtools/client/themes/webconsole.css:767
(Diff revision 1)
> +  --border-size: 3px;
> +  border-inline-start: var(--border-size) solid transparent;
> +}
> +
> +.webconsole-output-wrapper .message:hover {
> +  background-color: transparent !important;

This ends up overriding the background color for error messages (ie on http://bgrins.github.io/devtools-demos/console/errors.html).

I'd prefer to remove the original hover styling (https://dxr.mozilla.org/mozilla-central/source/devtools/client/themes/webconsole.css#220-222) along with this line.  I'm not too worried about dropping the hover from the old UI, I don't think it's providing a lot of help. Don't worry about getting the hover border working in the old UI, either.
Attachment #8897762 - Flags: review?(bgrinstead)
Comment on attachment 8897762 [details]
Bug 1390177 - Change message hover style. .

https://reviewboard.mozilla.org/r/168328/#review175118
Attachment #8897762 - Flags: review?(bgrinstead) → review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/88a206b95067
Change message hover style. r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/88a206b95067
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.