error during sync: NS_ERROR_FILE_ACCESS_DENIED

RESOLVED DUPLICATE of bug 1388024

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1388024
6 months ago
6 months ago

People

(Reporter: Tortino, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

278.30 KB, application/x-7z-compressed
Details
17.79 KB, application/x-7z-compressed
Details
(Reporter)

Description

6 months ago
Created attachment 8897025 [details]
sync error logs

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36

Steps to reproduce:

happens on nightly: 57.0a1 (2017-08-14) (64 bit)
1) created new profile
2) logged in sync
3) wait for sync to start



Actual results:

sync error:
1502725167139	addons.xpi	WARN	Failed to remove temporary file C:\Users\casel\AppData\Local\Temp\tmp-2cj.xpi for addon https://addons.mozilla.org/firefox/downloads/file/671858/link_cleaner-1.5-an+fx.xpi?src=sync: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: removeTemporaryFile :: line 1592"  data: no] Stack trace: removeTemporaryFile()@resource://gre/modules/addons/XPIInstall.jsm:1592 < startInstall/<()@resource://gre/modules/addons/XPIInstall.jsm:1960 < waitForSyncCallback()@resource://services-common/async.js:97 < makeSpinningCallback/callback.wait()@resource://services-common/async.js:166 < create()@resource://services-sync/engines/addons.js:317



Expected results:

sync should complete without errors
(Reporter)

Comment 1

6 months ago
I deleted all TEMP files, restarted windows, and retries sync.
Now I got a different error:

1502727006843	Sync.Engine.Extension-Storage	ERROR	Syncing storage-sync-crypto: request failed: Error: HTTP 503; SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data (resource://services-common/kinto-http-client.js:2353:21) JS Stack trace: processResponse@kinto-http-client.js:2351:44 < async*request@kinto-http-client.js:2431:14 < async*execute@kinto-http-client.js:744:26 < async*paginatedList@kinto-http-client.js:850:34 < async*listRecords@kinto-http-client.js:2065:14 < async*[6]</pullChanges/<@kinto-offline-client.js:1761:45 < step@kinto-offline-client.js:872:183 < [6]</_asyncToGenerator/</</step/<@kinto-offline-client.js:872:361 < promise callback*step@kinto-offline-client.js:872:314 < [6]</_asyncToGenerator/</<@kinto-offline-client.js:872:437 < [6]</_asyncToGenerator/<@kinto-offline-client.js:872:99 < pullChanges@kinto-offline-client.js:1735:12 < [6]</sync/<@kinto-offline-client.js:2019:15 < step@kinto-offline-client.js:872:183 < [6]</_asyncToGenerator/</<@kinto-offline-client.js:872:437 < [6]</_asyncToGenerator/<@kinto-offline-client.js:872:99 < sync@kinto-offline-client.js:1998:12 < _syncCollection/<@ExtensionStorageSync.jsm:829:14 < _requestWithToken@ExtensionStorageSync.jsm:840:20 < async*_syncCollection@ExtensionStorageSync.jsm:821:12 < sync@ExtensionStorageSync.jsm:596:12 < async*_syncKeyRing@ExtensionStorageSync.jsm:1022:28 < async*checkSyncKeyRing@ExtensionStorageSync.jsm:989:13 < async*syncAll@ExtensionStorageSync.jsm:730:11 < async*_sync@extension-storage.js:40:12 < async*WrappedNotify@util.js:181:27 < async*sync@engines.js:722:12 < async*_syncEngine@enginesync.js:203:13 < async*sync@enginesync.js:153:21 < async*onNotify@service.js:1099:13 < async*WrappedNotify@util.js:181:27 < async*WrappedLock@util.js:137:22 < async*_lockedSync@service.js:1092:12 < async*sync/<@service.js:1084:13 < async*WrappedCatch@util.js:107:22

and again this error that I already reported in bug 1388024:

1502727006386	Sync.Engine.History	WARN	Got exception, aborting processIncoming: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [mozIAsyncHistory.updatePlaces]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://services-sync/engines/history.js :: applyIncomingBatch/< :: line 220"  data: no] Stack trace: applyIncomingBatch/<()@resource://services-sync/engines/history.js:220 < applyIncomingBatch()@resource://services-sync/engines/history.js:212

(I'll attach new sync logs with these errors)
(Reporter)

Comment 2

6 months ago
Created attachment 8897032 [details]
other error logs

Updated

6 months ago
Component: Untriaged → Sync
> 1502725167139	addons.xpi	WARN	Failed to remove temporary file C:\Users\casel\AppData\Local\Temp\tmp-2cj.xpi for addon https://addons.mozilla.org/firefox/downloads/file/671858/link_cleaner-1.5-an+fx.xpi?src=sync

IIUC, that's just a warning, and not really actionable. (IOW, it's expected that removing the temporary file might fail, and doesn't necessarily mean there's a problem). Did the sync still finish?

> 1502727006843	Sync.Engine.Extension-Storage	ERROR	Syncing storage-sync-crypto: request failed: Error: HTTP 503; SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

This looks like bug 1388830.
Flags: needinfo?(tortino)

Comment 4

6 months ago
Digging a little more here, the logs show:

> 1502725613835	Sync.Engine.History	WARN	Got exception, aborting processIncoming: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [mozIAsyncHistory.updatePlaces]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource://services-sync/engines/history.js :: applyIncomingBatch/< :: line 220"  data: no] Stack trace: applyIncomingBatch/<()@resource://services-sync/engines/history.js:220 < applyIncomingBatch()@resource://services-sync/engines/history.js:212

which is roughly the same exception we were seeing in bug 1388024 - although the logs there were implying PlacesUtils.history.insertMany was the problem (via bug 1377944), although that doesn't seem to be related.

I'm going to close this as a dupe of bug 1388024.
Flags: needinfo?(tortino)

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388024
You need to log in before you can comment on or make changes to this bug.