Customization tab opens in popup window

RESOLVED FIXED in Firefox 57

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mkaply, Assigned: Gijs)

Tracking

Trunk
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
If you open a popup window (easiest way is to go to gmail and hold shift on the compose pop out) and then select customize, the customization UI opens in the popup window (and you can't actually customize anything because there are no toolbars).

It should open in the main window.
(Reporter)

Updated

2 years ago
Blocks: 1015163
(Assignee)

Updated

2 years ago
OS: iOS 10 → All
Hardware: x86 → All
(Assignee)

Updated

2 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Reporter)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8897381 [details]
Bug 1390260 - make customize mode work in popup windows,

https://reviewboard.mozilla.org/r/168698/#review174016
Attachment #8897381 - Flags: review?(mozilla) → review+

Comment 3

2 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fb0d8aeff611
make customize mode work in popup windows, r=mkaply
Backed out for failing mochitest browser_bug422590.js:

https://hg.mozilla.org/integration/autoland/rev/ec3db6c836161116d8358e80e407a7a82eca576f

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=fb0d8aeff611f9ede75681534cb3d3800cf4e6e1&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=runnable&filter-resultStatus=usercancel
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=123266507&repo=autoland

[task 2017-08-15T14:14:58.905869Z] 14:14:58     INFO - TEST-PASS | browser/base/content/test/general/browser_bug422590.js | got search bar - 
[task 2017-08-15T14:14:58.911325Z] 14:14:58     INFO - TEST-PASS | browser/base/content/test/general/browser_bug422590.js | search bar hidden - 
[task 2017-08-15T14:14:58.915809Z] 14:14:58     INFO - TEST-PASS | browser/base/content/test/general/browser_bug422590.js | search bar hidden - 
[task 2017-08-15T14:14:58.917740Z] 14:14:58     INFO - TEST-PASS | browser/base/content/test/general/browser_bug422590.js | got file menu - 
[task 2017-08-15T14:14:58.922595Z] 14:14:58     INFO - TEST-PASS | browser/base/content/test/general/browser_bug422590.js | file menu initially enabled - 
[task 2017-08-15T14:14:58.926051Z] 14:14:58     INFO - Buffered messages finished
[task 2017-08-15T14:14:58.934783Z] 14:14:58     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug422590.js | Test timed out -
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1385044
Comment hidden (mozreview-request)
(Reporter)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8897476 [details]
Bug 1390260 - remove old customize test, add test that checks it works in main window,

https://reviewboard.mozilla.org/r/168770/#review174096
Attachment #8897476 - Flags: review?(mozilla) → review+

Comment 8

2 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fcadf039a35d
make customize mode work in popup windows, r=mkaply
https://hg.mozilla.org/integration/autoland/rev/ea6b6c96a66f
remove old customize test, add test that checks it works in main window, r=mkaply
(Assignee)

Updated

2 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fcadf039a35d
https://hg.mozilla.org/mozilla-central/rev/ea6b6c96a66f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Comment 10

2 years ago
I have reproduced this bug with Nightly 57.0a1 (2017-08-14) on Windows 8.1 !

This bug's fix is verified with latest Nightly!

Build Id   : 20170820100343
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

[bugday-20170816]
I have reproduced this bug with Nightly 57.0a1 (2017-08-14) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!

Build  ID  : 20170823100553 
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170823]
You need to log in before you can comment on or make changes to this bug.