Closed Bug 1390264 Opened 3 years ago Closed 3 years ago

Hovering over pocket icon in popup window causes the URL bar to shift

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: mkaply, Assigned: jaws)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-animation])

Attachments

(2 files)

Attached video pocket_shift.mov
See attached video. If you hover over the pocket icon in a popup window, the url bar shifts.
Which nightly is this? What version of OS X? Does this reproduce with servo/stylo disabled? How about safe mode? Clean profile with a popup that isn't from a logged-in gmail session ( I find running this in a web console helpful: document.body.addEventListener("click", () => window.open("", "_blank", "height=200")) ) ?

This could be a frontend issue, but equally looks like something that might be a graphics/layout issue. It'd help if we could narrow this down further, but for now, I can't quickly repro on my own OS X nightly (today, osx 10.12.6)
Flags: needinfo?(mozilla)
Ah, never mind, I need an actual URL in the window, about:blank doesn't do.
Flags: needinfo?(mozilla)
Jared, this seems to be happening because the animatable box unhides on :hover. Any idea what's up?
Blocks: 1387077
Flags: needinfo?(jaws)
(In reply to Johann Hofmann [:johannh] from comment #3)
> Could this be from bug 1389740?

Or that. They both landed in the same nightly, from different branches, so that was fun... (x-ref bug 1390182 as well)
See Also: → 1390182
Component: General → Theme
We unhide it on :hover to preload the animation. We shouldn't do this in windows with chromehidden because the toolbar won't have position:relative.
Flags: needinfo?(jaws)
I can reproduce this on latest Linux Nightly, 57.0a1 (2017-08-14) (64-bit).

This is specific to the Pocket icon -- it does not happen with the bookmark or "..." icons.

STR:
 1. Compose an email message in Gmail.
 2. Shift-click the diagonal-expanding-arrows icon at the top right of your compose-new-message pane. (This should pop out a smaller dialog for your email message.)
 3. Hover the pocket icon in the (non-editable) URL bar for that smaller window.

ACTUAL RESULTS: The entire contents of the URL bar shift upwards by several pixels.  The .../star/pocket icons at the right side shift slightly leftwards, too.
Whiteboard: [photon-animation][triage]
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 57.2 - Aug 29
Priority: P3 → P1
Comment on attachment 8897972 [details]
Bug 1390264 - Only set up the pocket-animatable-box when animation should begin.

https://reviewboard.mozilla.org/r/169282/#review174640
Attachment #8897972 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1770d65a3428
Only set up the pocket-animatable-box when animation should begin. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/1770d65a3428
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Flags: qe-verify? → qe-verify+
QA Contact: stefan.georgiev
User Agent    Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build   ID    20170830100230

This bug fix is Verified with latest Nightly 57.0a1.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.