bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Awesomebar intermittently doesn't recognise URLs if not followed by a '/'

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
11 months ago
10 months ago

People

(Reporter: gw280, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170814100258

Steps to reproduce:

I can't reproduce this reliably, so this may not be actionable. :(

* Type a URL into the Awesomebar, e.g. reddit.com/r/canada
* Hit Enter


Actual results:

Nothing


Expected results:

Browser should have navigated to reddit.com/r/canada. Instead, I had to ensure there was a trailing / before it would work.
(Reporter)

Updated

11 months ago
Component: Untriaged → Location Bar

Comment 1

11 months ago
I'm assuming you didn't flip the extensions.legacy.enabled pref to true (so it's set at its default "false" value)?

Any specific add-ons to report, even webextensions that may interact with the location bar?

Updated

11 months ago
Flags: needinfo?(gw)
(Reporter)

Comment 2

11 months ago
Sorry for the late reply, been on PTO.

Anyway, I don't have any extensions except for Cisco WebEx installed. That pref is the default (false).
Flags: needinfo?(gw)
This bug isn't actionable as it is, but feel free to reopen if you can get a reliable set of STR.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.