Replace fox icon on the new tab and tour notifications with the Firefox logo

RESOLVED DUPLICATE of bug 1392468

Status

()

Firefox
Activity Streams: Newtab
RESOLVED DUPLICATE of bug 1392468
11 months ago
11 months ago

People

(Reporter: nicoleyee, Unassigned)

Tracking

unspecified
Firefox 57
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(URL)

(Reporter)

Description

11 months ago
Replace the fox head icon with the new firefox icon

A) Use the colorized version when it’s “talking” to you about onboarding, 
B) When onboarding is completed or dismissed then we show the single-color version. 

https://mozilla.invisionapp.com/share/KFD16G9AU#/248596305_New_Tab_-_Firefox_Logo
(Reporter)

Updated

11 months ago
Whiteboard: [photon-onboarding][triage]
Target Milestone: --- → Firefox 57
Version: 57 Branch → unspecified
(Reporter)

Comment 1

11 months ago
Also, change the fox head in the tour notification to the color Firefox logo.

Updated

11 months ago
Summary: Implementing Firefox logo on New Tab → Replace fox icon on the new tab and tour notifications with the Firefox logo

Comment 2

11 months ago
> B) When onboarding is completed or dismissed then we show the single-color
> version. 

Can you provide a more clear definition for this? 
Is `onboarding is complete or dismissed` means user checked the `hidden` checkbox, and now we won't hide the icon but show a single-color version? 
And what is the behavior of the single-color version, does user still able to click on it?
Flags: needinfo?(nyee)
Flags: needinfo?(mverdi)

Comment 3

11 months ago
And please provide the related icon asset.

BTW if we need to change the current behavior beyond changing the icon image, it will be a very late feature for v57.
Does it need to be a separate logo file or can it just reuse one of these:

chrome://branding/content/about-logo@2x.png
chrome://branding/content/icon64.png

Those come from https://searchfox.org/mozilla-central/source/browser/branding/official/content or https://searchfox.org/mozilla-central/source/browser/branding/nightly/content or others based on channel.

Comment 5

11 months ago
(In reply to Fred Lin [:gasolin] from comment #2)
> > B) When onboarding is completed or dismissed then we show the single-color
> > version. 
> 
> Can you provide a more clear definition for this? 
> Is `onboarding is complete or dismissed` means user checked the `hidden`
> checkbox, and now we won't hide the icon but show a single-color version? 
> And what is the behavior of the single-color version, does user still able
> to click on it?

When the tour is marked complete and we would normally remove the fox icon we should now replace it with the single-color version. You should not be able to click on the single-color version.

(In reply to Fred Lin [:gasolin] from comment #3)
> And please provide the related icon asset.

Do we need to have our own copies of these or can we use those already in the product?
Flags: needinfo?(mverdi)

Comment 6

11 months ago
> > Is `onboarding is complete or dismissed` means user checked the `hidden`
> > checkbox, and now we won't hide the icon but show a single-color version? 
> > And what is the behavior of the single-color version, does user still able
> > to click on it?
> 
> When the tour is marked complete and we would normally remove the fox icon
> we should now replace it with the single-color version. You should not be
> able to click on the single-color version.
> 

Thanks for explain. So when user checked `Mark all as complete, and hide the tour`,
we won't hide the icon but show a single-color, non-functional version instead.

Then 2 questions need to be resolved:
1. when user scale down window width to < 960px, should we hide the icon as we did now?
2. the string is incorrect(since we only make it non-functional but not hide it), we need to change the string

> (In reply to Fred Lin [:gasolin] from comment #3)
> > And please provide the related icon asset.
> 
> Do we need to have our own copies of these or can we use those already in
> the product?

if we already have both icons in repo then it will be fine.


I also noticed the message bubble shape and color are changed as well, is there a more through UI spec?
Flags: needinfo?(nyee) → needinfo?(mverdi)

Comment 7

11 months ago
(In reply to Fred Lin [:gasolin] from comment #6) 
> I also noticed the message bubble shape and color are changed as well, is
> there a more through UI spec?

I don't believe we're changing the message bubble at this time.
Flags: needinfo?(mverdi)

Comment 8

11 months ago
dup of bug 1392468 and related bugs, tracked in https://mzl.la/2eGRnbN
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1392468

Updated

11 months ago
Whiteboard: [photon-onboarding][triage]
You need to log in before you can comment on or make changes to this bug.