Retry without the fast open on NS_ERROR_FAILURE

RESOLVED FIXED in Firefox 57

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dragana, Assigned: dragana)

Tracking

57 Branch
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
In waiting for bug 1386719 to be reviewd by a nspr peer, I made a work around for it in bug 1389079 that retries connection if ContinueConnect returns NS_ERROR_FAILURE.

I forgot to add this error to the list in SetFastOpenConnected :(
(Assignee)

Comment 1

2 years ago
Attachment #8897417 - Flags: review?(mcmanus)
Attachment #8897417 - Flags: review?(mcmanus) → review+

Comment 3

2 years ago
Pushed by dd.mozilla@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/996189aa5b6f
Retry without fast open if error is NS_ERROR_FAILURE. r=mcmanus
I see a talos improvement from this landing:
== Change summary for alert #8797 (as of August 15 2017 17:38 UTC) ==

Improvements:

 19%  sessionrestore_many_windows windows10-64 pgo e10s     4,649.83 -> 3,783.67

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=8797

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/996189aa5b6f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1384957
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1381256
You need to log in before you can comment on or make changes to this bug.