Can't see the bookmark folders on the new library menu

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WONTFIX
8 months ago
7 months ago

People

(Reporter: Alexandre Folle de Menezes, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

(Reporter)

Description

8 months ago
The old bookmarks "star" menu is gone, and I guess it is supposed to be replaced by the library menu.  The problem is that the new bookmarks entry on this menu won't show my bookmark folders, which is a serious usability issue.
I suggest implementing the folder support as a blocking issue, or bringing back the star button by default.
Whiteboard: [photon][triage]
The bookmarks menu is a new button that you can add to the toolbar in customization. The Library button only shows recent bookmarks, without a structure.
Whiteboard: [photon][triage] → [photon-structure][triage]
(Reporter)

Comment 2

8 months ago
Yep, that's exactly what I described as the problem.

The bookmarks menu was already a customizable button before, what changed is that it is now removed by default every time the browser starts.  If you really hate it, it should be only be off for new users.  Its supposed replacement, the library button, does not implement the same functionality since it is impossible to find your older bookmarks.

Comment 3

8 months ago
(In reply to Alexandre Folle de Menezes from comment #2)
> The bookmarks menu was already a customizable button before, what changed is
> that it is now removed by default every time the browser starts.

I don't really understand what you're saying here. If you put the bookmarks menu button back in the toolbar from customize mode or using Library > Bookmarks > Bookmarking Tools > Add Bookmarks Menu to Toolbar, is it automatically / magically removed after you restart Firefox? That should not be the case.
Flags: needinfo?(alex.fdm)
(Reporter)

Comment 4

8 months ago
Sorry, my explanation was not complete.  I have the three versions installed (55, 56 and 57).  If I open 57, the toolbar layout is reset and the Bookmarks button is removed.  I can add it back and it will stay there IF I keep using only 57.  If I open 55 or 56, the Bookmarks button is also still there, but as soon as I open 57 again the button is removed again.

I know this is not a common user case.  What I mean is that if I care enough to create folders on my bookmarks is because I want those folders and don't want them to go missing.  Let's say that I am a user who cares about the bookmark folders and have never customized the interface.  I upgrade to Firefox 57 with its all-new look and find the Bookmarks item in the new Library button.  I assume that's the way it works now (because it's a new interface after all) and either get angry because I can't find the bookmarks anymore or I revert to a previous version and get even more angry because the bookmarks button is missing and there's no way to my bookmarks them anymore.

What I am suggesting is that you don't hide the Bookmarks button from existing users, only from new ones.  Or at least don't hide the button from users who care enough to create bookmark folders.
Flags: needinfo?(alex.fdm)

Comment 5

8 months ago
(In reply to Alexandre Folle de Menezes from comment #4)
> Sorry, my explanation was not complete.  I have the three versions installed
> (55, 56 and 57).  If I open 57, the toolbar layout is reset and the
> Bookmarks button is removed.  I can add it back and it will stay there IF I
> keep using only 57.  If I open 55 or 56, the Bookmarks button is also still
> there, but as soon as I open 57 again the button is removed again.

OK, this makes more sense to me. Thanks for explaining. Yes, this is more or less expected behaviour (not entirely, tbh, but also not something we're likely to fix).

> I know this is not a common user case.  What I mean is that if I care enough
> to create folders on my bookmarks is because I want those folders and don't
> want them to go missing.  Let's say that I am a user who cares about the
> bookmark folders and have never customized the interface.  I upgrade to
> Firefox 57 with its all-new look and find the Bookmarks item in the new
> Library button.  I assume that's the way it works now (because it's a new
> interface after all) and either get angry because I can't find the bookmarks
> anymore or I revert to a previous version and get even more angry because
> the bookmarks button is missing and there's no way to my bookmarks them
> anymore.

I don't think I buy users would never click "bookmarking tools" (which is right at the top of library > bookmarks, before your bookmarks!), and not just find you can add the bookmarks menu button back, or use the sidebar or toolbar, and then continue happily. Or find you can search for bookmarks in the location bar using Library > Bookmarks > Search (and eventually you figure out you can just do this directly from the location bar), which is usually much quicker than navigating lots of folders. Yes, it's a change from their current workflow, but hopefully it's a change for the better. Certainly there's shortcuts for the sidebar and for the location bar and so ultimately it's likely to be a lot quicker than mousing to open the bookmark menu button and then navigating multi-level bookmarks folders.

> What I am suggesting is that you don't hide the Bookmarks button from
> existing users, only from new ones.

This doesn't really make sense - if one of these defaults is worse than the other, we're just depriving the other set of users of a better experience.

>  Or at least don't hide the button from
> users who care enough to create bookmark folders.

There's no reasonable way to have different toolbar layouts depending on how many bookmarks (folders) a user has - certainly not in a way that would survive a user clicking "restore defaults" in customize mode, which is ultimately what you're asking for. And then should we hide the item again if the folders get removed? It gets really messy...

We could potentially consider adding it initially/once for users with lots of bookmarks once we realize they have them, but then it'd get removed if they used "restore defaults" or Firefox refresh or anything like that - it'd just be a one-time "we think you're likely to want this so we'll go through adding it for you", which would just mean they wouldn't know how to remove it or add it back (if we genuinely thought they couldn't figure that out without our help, which seems to be what you're suggesting by saying we need to do it for them...). So I'm not really convinced we should do this.

Bryan, do you think we need to do this (or anything else) in this space? If not, please close this, thanks!
Flags: needinfo?(bbell)
(Reporter)

Comment 6

8 months ago
(In reply to :Gijs from comment #5)
> (In reply to Alexandre Folle de Menezes from comment #4)
> > I know this is not a common user case.  What I mean is that if I care enough
> > to create folders on my bookmarks is because I want those folders and don't
> > want them to go missing.  Let's say that I am a user who cares about the
> > bookmark folders and have never customized the interface.  I upgrade to
> > Firefox 57 with its all-new look and find the Bookmarks item in the new
> > Library button.  I assume that's the way it works now (because it's a new
> > interface after all) and either get angry because I can't find the bookmarks
> > anymore or I revert to a previous version and get even more angry because
> > the bookmarks button is missing and there's no way to my bookmarks them
> > anymore.
> I don't think I buy users would never click "bookmarking tools" (which is
> right at the top of library > bookmarks, before your bookmarks!), and not
> just find you can add the bookmarks menu button back, or use the sidebar or
> toolbar, and then continue happily. Or find you can search for bookmarks in
> the location bar using Library > Bookmarks > Search (and eventually you
> figure out you can just do this directly from the location bar), which is
> usually much quicker than navigating lots of folders. Yes, it's a change
> from their current workflow, but hopefully it's a change for the better.
> Certainly there's shortcuts for the sidebar and for the location bar and so
> ultimately it's likely to be a lot quicker than mousing to open the bookmark
> menu button and then navigating multi-level bookmarks folders.
Yes, I access most of my frequent bookmarks via the awesomebar, which is much quicker than using the bookmarks menu.  But there's a different use case, in which I don't know the title or URL of the site I want to go, but it is neatly saved on a specific folder which I do remember.  And this use case is not contemplated by the new default interface.

> > What I am suggesting is that you don't hide the Bookmarks button from
> > existing users, only from new ones.
> 
> This doesn't really make sense - if one of these defaults is worse than the
> other, we're just depriving the other set of users of a better experience.
Nope, you are forcing your way to use the browser on the faithful users that are using their own way for years.  I know that everything is changing with the best of the intentions, but please consider that there is more than one way to do things, and maybe people are different and have different needs.

> >  Or at least don't hide the button from
> > users who care enough to create bookmark folders.
> 
> There's no reasonable way to have different toolbar layouts depending on how
> many bookmarks (folders) a user has - certainly not in a way that would
> survive a user clicking "restore defaults" in customize mode, which is
> ultimately what you're asking for. And then should we hide the item again if
> the folders get removed? It gets really messy...
I do expect things to change when I click "restore defaults".  I don't expect things to change when I turn on my computer and the browser was updated without asking or warning me. 

Please don't take me wrong, I do love Firefox and recommend it to all users I have influence over.  And I lost 2 users in the family the last time the UI changed just because the bookmarks button changed from one side of the interface to the other.  The argument was "if I have to learn a new interface, I'll just try this other browser everyone else is using".

Comment 7

8 months ago
> Bryan, do you think we need to do this (or anything else) in this space? If
> not, please close this, thanks!

I feel we did enough work make sure that returning the existing Bookmarks Menu was clear and easy to get back. We even went the extra mile to add quick access to the menu/toolbar/sidebar right into the new recent bookmarks report in the new Library. 

If a user feels they missed the stand alone bookmarks menu, and I truly believe bookmarks filers will, the remedy for them is only a couple clicks away.
Flags: needinfo?(bbell)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX

Updated

8 months ago
Whiteboard: [photon-structure][triage]
Duplicate of this bug: 1399426
status-firefox57: affected → wontfix
You need to log in before you can comment on or make changes to this bug.