Certain extensions don't download but are displayed (.gz)

VERIFIED DUPLICATE of bug 124787

Status

VERIFIED DUPLICATE of bug 124787
17 years ago
2 years ago

People

(Reporter: billc, Assigned: law)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
You can see this behavior when trying to download the latest mozilla Mach-O
build.   Trying to Save Link Target As, doesn't work.  One can argue that the
webserver isn't doing the right thing with mime-types, but the problem if very
far reaching.  Because Mozilla will read a mime-type gzip, shouldn't preclude it
to displaying a filetype of .gz

Other issues exist with file extentions like .dmg, where it will again display
it, mostly because the large number of servers out there do not have .dmg in the
mime-file.

For example, there are two different behaviors:
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-macho-macosx-trunk.dmg.gz
and
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-macho-macosx-trunk.dmg.gz

Understandably, two different protocols, but from a user standpoint, there
shouldn't be any difference in how mozilla responds to this.  In both cases a
file save should pop up (imho).
(Reporter)

Comment 1

17 years ago
Correction to above:  "shouldn't preclude it to -downloading- a filetype of .gz"

also: Save Link Target As.. does work, it was Finder that wasn't updating the
desktop after it had completed.
The http case sends us a "content-type: text/plain" header as well as
"content-encoding: gzip" header.  Since we handle content decoding, we decode it
and show the content.  This is the correct behavior.  The server is quite simply
misconfigured.

Mozilla should under no circumstances be overriding the server-provided type for
http requests.  No browser except IE does so, by the way.  Individual servers
that are broken should have evangelism bugs filed on them.

Marking duplicate of ".gz files on http://ftp.mozilla.org/ have MIME type
text/plain"

*** This bug has been marked as a duplicate of 124787 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.