Opening Preferences clears without confirmation any in-progress Preferences changes

RESOLVED WONTFIX

Status

()

Firefox
Preferences
RESOLVED WONTFIX
4 months ago
3 months ago

People

(Reporter: atoll, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
Steps to reproduce:

1. Open Preferences. Select "Use Bookmark...", do nothing else here.
2. Open a new tab. Pretend you did something in it, though nothing is required.
2. Press Cmd-, or go to Nightly -> Preferences... again.

Expected result:

I'm returned to the Preferences tab.

Actual result:

I'm returned to the Preferences tab, my in-progress Bookmark selection is cleared, and the entire tab reloads, flickering the tab title briefly to about:preferences and then back to Preferences.
Component: General → Tabbed Browser
OS: Unspecified → All

Updated

4 months ago
Component: Tabbed Browser → Preferences
Whiteboard: [photon-preferences] [triage]

Updated

4 months ago
Whiteboard: [photon-preferences] [triage] → [photon-preference][triage]
This is by-design. It's entirely possible the next loading of Preferences needs to take the user to another section or pane, even if we probe the currently loaded section/pane we cannot prevent reloading/switching in that case.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX

Comment 2

3 months ago
remove whiteboard tag due to its WONTFIX
Whiteboard: [photon-preference][triage]
You need to log in before you can comment on or make changes to this bug.