Flexible spaces keep reappearing when dragged out of the toolbar in customize mode

RESOLVED DUPLICATE of bug 1393574

Status

()

defect
RESOLVED DUPLICATE of bug 1393574
2 years ago
2 years ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
All
macOS
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Built from https://hg.mozilla.org/mozilla-central/rev/564e82f0f289af976da01c2d50507017bbc152b5

Steps to reproduce:
 1. Create a new profile.
 2. Go into toolbar customization.
 3. Add another flexible space behind the search bar.
 4. Try to remove the first flexible space behind the search bar.

Expected results:
The flexible space should disappear after you've dragged it out of the toolbar.

Actual results:
The flexible space keeps reappearing at the end of the drag.

I'm attaching a screen recording. In this recording, for some reason the flexible space that I was adding was added in the wrong place.
Reporter

Comment 1

2 years ago
Posted video screen recording

Comment 2

2 years ago
I know this is going to be weird and maybe frustrating because I can see the screencast, but I still can't really reproduce what's in the summary here.

I am also confused because your clean profile's screenshot button isn't where it should be (in the toolbar - it's in the palette instead). So something odd is up. Is this regular nightly? Local build? Something else?

It seems like the times you can't drag the spacer out, you end up trying to drop it on the panel or the edge of the panel. Dragging spacers to the panel deliberately doesn't work (because flexible space inside the panel doesn't really make sense). The only usable drag target is another toolbar or the "more tools" area. On non-OSX this is more obvious because drag cursors work better and so you get a "not allowed" style cursor, see also e.g. bug 1320065 .

I do think that:

- we could make it easier by making them disappear if dragged to the panel (but then, would that be reasonable behaviour for people who are genuinely trying to put the space in the panel?), and
- by fixing the OS X widget bugs here, and maybe
- for at least 1 of your drags, by making the dead space underneath the panel also "count" as a drag to the palette (after all, there's no border there so to the user it presumably feels like it's one space with the "more tools" area, but layout-wise it isn't, and until photon it didn't look like one space either...).

Does that sound like an accurate assessment of what could be done to make this better, or does it still seem like there is something else that needs fixing here?


As for the button ending up in the wrong place, buttons get put at the end if you drop them on top of the toolbar rather than the button (the empty space that appears is a transparent border on the neighbouring button/element/thing). At least on my OS X machine, checking with the browser toolbox, there's no margin between items and no height difference between elements and the containing navbar customization target, so I'm not sure how you're managing to do that - unfortunately, I can't reproduce that either. :-(
Flags: needinfo?(mstange)

Comment 3

2 years ago
So, bug 1396423 covers expanding the droppable area for spacers, and bug 1393574 covers issues with removing spacers (but has STR), so I will close this out as a dupe of the latter. Please reopen if you think there is something else that needs doing.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mstange)
Resolution: --- → DUPLICATE
Duplicate of bug: 1393574
You need to log in before you can comment on or make changes to this bug.