Closed Bug 139061 Opened 19 years ago Closed 19 years ago

'sidebar' and 'addressbooks' fighting over space

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 121583

People

(Reporter: wouter-mozilla, Assigned: racham)

Details

Attachments

(2 files)

When I open the addressbook with both the 'addressbooks' and 'sidebar' active at
the left, my cpu usage runs up to 100% and the sidebar is shaking up and down
really fast.

I think the slider between the 'addressbooks' area and the 'sidebar' area is
trying to set itself at a certain optimal position, but while doing so, triggers
something (showing of scrollbar?) and gets in an infinite loop, causing the
position to shift slightly up and down really fast.

Mozilla does not crash or hang, and the slider (the seperator between this
addressbook area and the sidebar) can be dragged up or down, causing the shaking
to stop.

It only happens when opening the addressbook with the sidebar in a certain
position - just a bit under the last addressbook entry (see screenshot), and not
when you change the position with the addressbook open.

I hope I made myself clear here :)

I added two screenshots, the first showing the constant redrawing, 'shaking',
with the sidebar hopping up and down; and the second one, showing in which
position this hmmm... 'effect' occurs.

I think there's a small bug in the code that sets the geometry (and more
exactly, the upper boundary) of the sidebar - but I really have no idea how to
debug a condition like this.

I can reproduce this any time (mozilla 1.0rc1 compiled from source on linux). I
suspect this can be reproduced on at least any recent linux compilation, playing
a bit with the distance of the addressbook-list and the sidebar, according to
your screen resolution.
I'm not sure this shot's really useful for people without a great deal of
imagination... :)
Another manifestation of bug 121583 - resolving as dup.
(see also bug 124530 & bug 122153)

*** This bug has been marked as a duplicate of 121583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.