Closed Bug 1390610 Opened 7 years ago Closed 7 years ago

stylo: clear the WAS_RESTYLED flag in set_traversed_without_styling

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED INVALID

People

(Reporter: bholley, Unassigned)

References

Details

Attachments

(1 file)

The basic idea is to reset all the restyle state flags on elements whenever we traverse them. I tried doing this in bug 1390179, but it caused timeouts in three devtools tests:

devtools/client/responsive.html/test/browser/browser_device_change.js
devtools/client/responsive.html/test/browser/browser_dpr_change.js
devtools/client/responsive.html/test/browser/browser_touch_device.js

My best guess here is that we have some bug that's preventing the post-traversal from reaching the element, but then we somehow manage to reach the element later on, and leaving the WAS_RESTYLED flag allows us to pick up it up in some other post-traversal down the road, if one happens (in these three tests, presumably it does).

One of those tests is already timing out intermittently, so it seems plausible that this might be causing other flakiness in devtools tests and elsewhere. Could be an interesting lead to investigate to see if it reduces timeouts in other tests.
This is the patch that caused the three devtools tests to time out. We should
investigate those timeouts, fix them, and then land this patch.

MozReview-Commit-ID: Cb5MuKhgu8J
(And to be clear, this reproduced just fine in a local debug build).
I suspect it has to do with the second traversal we do for animation stuff, wouldn't we be unsetting stuff there incorrectly?
(In reply to Emilio Cobos Álvarez [:emilio] from comment #3)
> I suspect it has to do with the second traversal we do for animation stuff,
> wouldn't we be unsetting stuff there incorrectly?

Ah! That's a great point. We can actually have up to four traversals before the post-traversal, and since we depend on WAS_RESTYLED in the post-traversal, the approach here isn't valid.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: