Linked stylesheet fluke.

VERIFIED INVALID

Status

Tech Evangelism Graveyard
English US
--
minor
VERIFIED INVALID
16 years ago
3 years ago

People

(Reporter: Rob McMeekin, Assigned: Marc Attinasi)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041717

This fluke has been bothering me since I first started using Mozilla (0.9.2.1-2
&#173; 1.0rc1-0). <a
href="http://www.speakeasy.org/~rob-mcmeekin/index.html">One page</a> has a
stylesheet linked with the tag &lt;link rel=&quot;stylesheet&quot;
type=&quot;text/css&quot; href=&quot;<a
href="http://www.speakeasy.org/~rob-mcmeekin/style.css"
type="text/plain">style.css</a>&quot;&gt;. A <a
href="http:/www.speakeasy.org/~rob-mcmeekin/inline.html">second page</a> has the
same stylesheet inline with the &lt;style type=&quot;text/css&quot;&gt; ...
&lt;/style&gt; tags. Both pages look the same when I view the from my hard disk,
but when I view them from a server&#8212;be it my localhost server or my service
provider's (which both happen to be apache 1.3 I believe)&#8212;Mozilla refuses
to display the first page with the stylesheet, but it displays the second one
fine. Other browsers I tried worked consistently for both pages (Internet
Explorer 5.0 and Netscape 4.73 under WinME). I have only tested this with
Mozilla under Red Hat Linux 7.2.

Reproducible: Always
Steps to Reproduce:
1. Load <a
href="http://www.speakeasy.org/~rob-mcmeekin/index.html">index.html</a> in
Mozilla under Linux. You will not find evidence of the stylesheet referenced in
the &lt;head&gt; section.
2. Download <a href="http://www.speakeasy.org/~rob-mcmeekin/index.html"
type="text/plain">index.html</a> along with<a
href="http://www.speakeasy.org/~rob-mcmeekin/style.css"
type="text/plain">style.css</a>&#8212;the referenced stylesheet&#8212; and view
the page locally. You will notice evidence of a stylesheet.
3. Load <a
href="http://www.speakeasy.org/~rob-mcmeekin/inline.html">inline.html</a> in
Mozilla under Linux. You will notice evidence of a stylesheet and if you compare
the inline stylesheet code with the <a
href="http://www.speakeasy.org/~rob-mcmeekin/style.css"
type="text/plain">style.css</a> code, you'll find they are the same.

Actual Results:  Just as described above.

Expected Results:  The page should have been displayed consistently.
When you activate Mozilla 'strict mode' (by using a Strict doctype), the
stylesheet mimetype should be text/css. Wrong mimetypes, such as text/plain,
will make Mozilla ignore the stylesheet.

-> Tech Evangelism, confirming
Status: UNCONFIRMED → NEW
Component: Layout → Authors
Ever confirmed: true
Product: Browser → Tech Evangelism
Version: other → unspecified
Rob: and btw. the CSS validator http://jigsaw.w3.org/css-validator/ will find an
error:

padding; 0px;
(Reporter)

Comment 3

16 years ago
OK. I fixed the padding; 0px; and I put a copy of how my bug report was supposed
to look at http://www.speakeasy.org/~rob-mcmeekin/bug.html so that you guys can
read it. I still can't get the first(1) page to work right online though it
works fine locally and works fine remotely with other browsers.

The type is text/css in the file. The text/plain above was supposed to be part
of an anchor tag. My bad. ;-)

(1) http://www.speakeasy.org/~rob-mcmeekin/index.html
[21:06:33] mauricio@debian:/home/Mauricio$ telnet www.speakeasy.org 80
Trying 216.254.0.2...
Connected to grace.speakeasy.org.
Escape character is '^]'.
GET /~rob-mcmeekin/style.css HTTP1/1
Host: www.speakeasy.org

HTTP/1.1 200 OK
Date: Mon, 22 Apr 2002 00:08:05 GMT
Server: Apache/1.3.9 (Unix)
Last-Modified: Sun, 21 Apr 2002 23:52:39 GMT
ETag: "1f880-309-3cc350c7"
Accept-Ranges: bytes
Content-Length: 777
Connection: close
Content-Type: text/plain

Your server is still sending the CSS as text/plain...
(Reporter)

Comment 5

16 years ago
So what you're telling me is that it's supposed to do that. That does explain
things then.
(Reporter)

Comment 6

16 years ago
I guess it's really not a bug then.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
rubber stamp verified as reporter invalidated
Status: RESOLVED → VERIFIED

Comment 8

15 years ago
Moving to new component
Component: Authors → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.