Animation of Hamburger Subview(Library and More) is not smooth

VERIFIED FIXED in Firefox 57

Status

()

defect
P2
major
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: alice0775, Assigned: mikedeboer)

Tracking

(4 keywords)

57 Branch
Firefox 57
All
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ verified, firefox58 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Posted video screencast
Build Identifier:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170815100349


See attached screencast
(Reporter)

Comment 1

2 years ago
Posted file about:support
(Reporter)

Comment 2

2 years ago
The problem is not only Library Subview but also More Subview.
Summary: Animation of Hamburger Subview is not not smooth → Animation of Hamburger Subview(Library and More) is not not smooth
(Reporter)

Updated

2 years ago
Summary: Animation of Hamburger Subview(Library and More) is not not smooth → Animation of Hamburger Subview(Library and More) is not smooth
(Reporter)

Comment 3

2 years ago
[Tracking Requested - why for this release]:

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8ee32af87bd4ce492f0882184ab558a5a722dcad&tochange=ab84efbc748967c7c40d07f0e6ecddc3181fd306

Regressed by: a528b4400362	Gijs Kruitbosch — Bug 1382243 - Refactor panelmultiview code to reduce complexity and length of functions, r=mikedeboer
Severity: normal → major
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: perf, reproducible
OS: Windows 10 → Unspecified
Hardware: x86_64 → All

Updated

2 years ago
Duplicate of this bug: 1390625
I can repo on win7.
Keywords: polish
Priority: -- → P2
bug 1382243 is getting backed out.
Backout pushed to inbound.
Assignee: nobody → mdeboer
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57

Updated

2 years ago
Duplicate of this bug: 1391073
I managed to reproduce the bug using an older version of Nightly (2017-08-15) on Windows 10x64, macOS 10.13 and Ubuntu 16.04 x64.
I retested everything using latest Nightly 58 and beta 57.0b12 on the same platforms and the bug is not reproducing anymore.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.