Closed Bug 1390796 Opened 4 years ago Closed 4 years ago

3.63 - 3.86% tresize (windows7-32) regression on push 37ba4f932f57fc60bf27554b5d36df3c721df75f (Mon Aug 14 2017)

Categories

(Firefox :: Theme, defect)

53 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: jmaher, Assigned: johannh)

References

Details

(Keywords: perf, regression, talos-regression, Whiteboard: [fixed by 1390448])

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=37ba4f932f57fc60bf27554b5d36df3c721df75f

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  tresize windows7-32 opt e10s     11.64 -> 12.09
  4%  tresize windows7-32 pgo e10s     9.76 -> 10.11


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8806

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:johann, I see you authored the patch for this regression, could you take a look at this and determine if there is a fix we can do?
Strange. Technically that patch removed 2 sync reflows, so it should have had some positive effect. Anyway, I'm adding those back in bug 1390448 (which is already in review), so I suggest we wait until that lands.

If that doesn't have the desired effect, it can only be the extra media query we introduced for Windows 7, which would be quite strange/disappointing and I don't see how there's much we can do about that.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Depends on: 1390448
Flags: qe-verify-
This got reverted by bug 1390448 (https://bugzilla.mozilla.org/show_bug.cgi?id=1390448#c7)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by 1390448]
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.