Scrolling causes some images to redraw incorrectly

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: stephan, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
NOTE:  I have found a number of bugs in Bugzilla that seem to refer to this bug, 
but state "Works for me" or "Duplicate Fixed".  However, this is completely 
reproducible in 1.0RC1.

1.  Go to the listed URL.

2.  Note there are two GIF images on this page, one is the printed word "Rajika 
Puri" in the upper left corner, and one is the photo (woman with black hair) in 
the upper left of the white (non-menu bar) section of the page.

3.  Scroll down, could be by pressing down arrow key six or seven times.

4.  Scroll back up, could be by pressing up arrow key six or seven times.

5.  The text "Rajika Puri" in upper left is still rendered perfectly, however 
the GIF photo is ballocksed up.
To compositor
Assignee: mpt → kmcclusk
Component: User Interface Design → GFX Compositor
QA Contact: zach → petersen

Comment 2

17 years ago
WFM, XP, 2002041903
(Reporter)

Comment 3

17 years ago
Still happens for me, also see top left image in http://www.pfile.com/ .

It seems to me this has something to do with GIF images that have transparency 
in them.  So far I have seen such GIF images get messed up, and no others.

BTW, the screen does redraw properly if you press the REDRAW button, or if you 
bring another window to the top and then bring the browser window back to the 
top.
(Reporter)

Comment 4

17 years ago
I have found a new wrinkle to this bug...

It does NOT happen if JAVA is up and running.  So, if JAVA is used from
somewhere, and THEN I go to one of these pages where the transparency around a
GIF gets mucked up by scrolling, there is no problem.  But if I exit and restart
Mozilla and go to such a page (like the referenced one above,
http://www.rajikapuri.com/bio.html) and scroll the GIF on and off, the poor
redraw behavior is as described in the original bug.

Comment 5

17 years ago
Possible dup of bug 96803, where another user reports random distortion when
scrolling a gif with transparency.

Comment 6

17 years ago
I can't reproduce this problem in the July 16 build (2002-07-16-08 1.0.0) under
Windows ME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.