If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OS/2 version got SYS3175 when browsing this page then crash

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Hung-Te Lin, Assigned: mkaply)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    1.0 RC1 Release

The 1.0RC1 Release will crash when browsing
http://tw.yahoo.com/, causing a SYS3175
LIBUNI.DLL 0002:000047e7.

This is reproduced on OS/2 Version only, and
other platforms (eg: Windows) will not suffer
from this bug. And several OS/2 users also
got the same problem.

Reproducible: Always
Steps to Reproduce:
1. Browse http://tw.yahoo.com/


Actual Results:  SYS3175 appeared right away and Mozilla crashed

Expected Results:  Should browse succesfully.

Looks like some problem in locale converting
(LIBUNI.DLL).
CC mkaply (OS/2 only bug)
Severity: normal → critical
Keywords: crash
(Assignee)

Comment 2

16 years ago
Were you on an English system or Taiwanese system?

What did you have your fonts for Traditional Chinese set to?
(Reporter)

Comment 3

16 years ago
We were using Traditional Chinese version of OS/2 Warp 4.0
(The so-called TWarp4).

The font was set to MINCHO. 
And 'MINCHO System' also could not work.

Many Big5-encoded websites also got this problem.
By the way http://tw.yahoo.com/ will lead to crash
while http://chinese.yahoo.com/ will not.
So strange.

One more thing is that we couldn't display simplified
Chinese words for a long time...

Comment 4

16 years ago
Tested Mozilla build 20020507 on Taiwan zh_TW OS/2:
    used latest fixpak - convenience pack 2 version of Aurora, and Merlin
Set preferences/appearance/fonts - 
    Fonts for:traditional chinese, serif:MINCHO, sans serif:MINCHO
tw os/2 acp2 machine:fh1b f:\ 
tw os/2 mcp2 machine:fh4c k:\
tw os/2 4.5  machine:fh1d i:\

PASS - all could bring up http:\\tw.yahoo.com
I selected several links off main page - news, mail, advertisements.  
All Chinese characters displayed correctly

Are you using fixpak convenience pack 2?

Comment 5

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
Taiwan IBM don't provide the fixpak convenience pack 2 (or MCP) for Taiwan os/2 
user. I don't know that is Taiwan IBM's or USA IBM's tactic.
(Assignee)

Comment 7

16 years ago
What fixpak do you have applied to warp 4?

Comment 8

16 years ago
The latest Fixpak for TWarp4 is fixpak 5.

Comment 9

16 years ago
tested the latest mozilla 1.0 20020516 os/2 english on tw aurora system.
got a sys3175 in asiacol.dll after going to 3 links on tw.yahoo.com.
happens intermittently - after several links, different ones each time.
working on getting a tw os/2 4.0 fp 5 system.

Comment 10

16 years ago
asiacol.dll problem is posted as a bug 137693.
This dll seems to be added to OS/2 system around Aurora release.
I think os/2 4.0 fp5 don't have this dll.
(Assignee)

Comment 11

16 years ago
I just uploaded Mozilla RC3 and I did not optimize the NSLOCALE.DLL.

Can you see if this fixes the trap?

We are still investigating the problem.

I believe this trap is the same as the ASIACOL trap.
(Reporter)

Comment 12

16 years ago
This bug is not fixed in 1.0RC3.
And Warp 4.0 Chinese Edition (TWarp) with fp5
does not have the file named asiacol.dll.
(Assignee)

Comment 13

16 years ago
OK. We are working to get a Taiwanese system installed so we can debug it.
(Reporter)

Comment 14

16 years ago
One more comment.
If we uncheck the (Edit -> Pref -> Appearance -> Fonts) 
'Allow Documents to use other fonts', Mozilla can work
without crash.

So maybe this is caused by font choosing with Non-ASCII
font names. (eg: the Chinese name of Ming-Li fonts, mostly
used by Windows)
-> Mkaply
Assignee: Matti → mkaply
(Assignee)

Comment 16

15 years ago
Is it possible to narrow down the exact line that causes this please?

And then put the HTML on a website or in the bug?

Thank you.

I'd really like to get this problem solved.

Comment 17

15 years ago
The web font use "New-Micho" (from windows) crash the mozilla.
Only occuring on T-Warp4 + fixpak 5 (for I known)
(Assignee)

Comment 18

15 years ago
Do you know where I can get this font?

Comment 19

15 years ago
You can download this font file from :

http://www.sinica.edu.tw/~s822345/MINGLIU.TTC
It is true type font.
But be carefully that the font just used on Traditation Windows.
(Assignee)

Comment 20

14 years ago
Javier put in some new font code that resolves this issue.

We no longer use the collation code which crashes.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.