Intermittent browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N)

RESOLVED DUPLICATE of bug 1391507

Status

()

Firefox
Preferences
P5
normal
RESOLVED DUPLICATE of bug 1391507
3 months ago
3 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell fixed:other])

(Reporter)

Description

3 months ago
treeherder
Filed by: philringnalda [at] gmail.com

https://treeherder.mozilla.org/logviewer.html#?job_id=123474741&repo=autoland

https://queue.taskcluster.net/v1/task/Gu6FdFqAQymEtOBJVPM4og/runs/0/artifacts/public/logs/live_backing.log
Duplicate of this bug: 1391029

Comment 2

3 months ago
31 failures in 949 pushes (0.033 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 14
* mozilla-inbound: 11
* mozilla-central: 5
* try: 1

Platform breakdown:
* linux32: 30
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1390910&startday=2017-08-14&endday=2017-08-20&tree=all
this failure has really increased in frequency in the last couple days, all on linux32 debug.

here is a recent log file:
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-central&job_id=124880675&lineNumber=10873

and the related screenshot:
https://queue.taskcluster.net/v1/task/YVV0B3ACRF6jQGnLKARX5A/runs/0/artifacts/public/test_info//mozilla-test-fail-screenshot_zoQaJh.png

here is related failure information from the above log:
task 2017-08-22T14:29:58.343833Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.346113Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.350060Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.352369Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.359923Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.362184Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.365887Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.372276Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.375531Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.379934Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.383477Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.385878Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.389780Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Element should not be null, when checking visibility - 
[task 2017-08-22T14:29:58.392010Z] 14:29:58     INFO - TEST-PASS | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | Should not be in search results - 
[task 2017-08-22T14:29:58.396321Z] 14:29:58     INFO - Buffered messages logged at 14:29:53
[task 2017-08-22T14:29:58.400362Z] 14:29:58     INFO - Leaving test bound 
[task 2017-08-22T14:29:58.402632Z] 14:29:58     INFO - Buffered messages finished
[task 2017-08-22T14:29:58.406281Z] 14:29:58     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. - 
[task 2017-08-22T14:29:58.409537Z] 14:29:58     INFO - GECKO(1492) | MEMORY STAT | vsize 1042MB | residentFast 261MB | heapAllocated 92MB
[task 2017-08-22T14:29:58.413811Z] 14:29:58     INFO - TEST-OK | browser/components/preferences/in-content-new/tests/browser_search_subdialogs_within_preferences_7.js | took 95080ms


quite possibly we just need to extend the timeout given that we typically see many 90+ second test runs for this specific test.


:jaws, do you see other things we should do to this test?  are you ok with extending the runtime assuming that fixes the test?
Flags: needinfo?(jaws)
Whiteboard: [stockwell needswork]

Comment 4

3 months ago
50 failures in 143 pushes (0.35 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 31
* mozilla-inbound: 16
* mozilla-central: 2
* try: 1

Platform breakdown:
* linux32: 40
* linux32-stylo: 9
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1390910&startday=2017-08-22&endday=2017-08-22&tree=all
I don't see anything particular with this test, just that we need to make searching faster. Extending the time for this test is OK with me.
Flags: needinfo?(jaws)
fixing this with a patch in bug 1391507
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391507

Comment 7

3 months ago
50 failures in 173 pushes (0.289 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 37
* mozilla-inbound: 5
* mozilla-central: 5
* try: 3

Platform breakdown:
* linux32: 27
* linux32-stylo: 23

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1390910&startday=2017-08-23&endday=2017-08-23&tree=all

Comment 8

3 months ago
20 failures in 194 pushes (0.103 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 16
* try: 2
* mozilla-inbound: 1
* mozilla-central: 1

Platform breakdown:
* linux32-stylo: 14
* linux32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1390910&startday=2017-08-24&endday=2017-08-24&tree=all
Whiteboard: [stockwell needswork] → [stockwell fixed:other]

Comment 9

3 months ago
159 failures in 908 pushes (0.175 failures/push) were associated with this bug in the last 7 days. 

This is the #4 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 108
* mozilla-inbound: 30
* mozilla-central: 11
* try: 10

Platform breakdown:
* linux32: 109
* linux32-stylo: 49
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1390910&startday=2017-08-21&endday=2017-08-27&tree=all
You need to log in before you can comment on or make changes to this bug.