onchange event doesn't fire on SELECTs

VERIFIED DUPLICATE of bug 1190

Status

()

P1
normal
VERIFIED DUPLICATE of bug 1190
20 years ago
20 years ago

People

(Reporter: angus, Assigned: pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
When you change the selected option in a SELECT, the onchange event should fire.
It doesn't do this for me (11-16-98 12pm optimized build).
(Reporter)

Updated

20 years ago
Assignee: karnaze → pollmann
Component: Event%20Handling → Event Handling
Priority: P2 → P1
(Reporter)

Comment 1

20 years ago
Eric, now that joki wired up the events side of this stuff, it would be awesome
if select could do the right thing. A lot of sites use this feature in a sort of
"go" menu... Would be extremely useful for upcoming demos, etc... Upping
priority.

I just realized that the sites that use onchange probably also need the options
array and selectedIndex, which are separate bugs, I think.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

20 years ago
*** This bug has been marked as a duplicate of 1190 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Marking Verified as a dup.
You need to log in before you can comment on or make changes to this bug.